Defender Source Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
so about a 2 months i was doing a pre-trail inspection on my brothers 110 and i noticed the drain plug on the tranny was missing. it must have been missing for at least 4k miles because thats when it started to pick up a bit of a grind going into 2nd and 4th. so anyways after a month of waiting i dont think the drain pug that he ordered from the uk is going to show up. so im not to knowledgeable in the exact workings of a transmission, nor is my brother, it hasn't been started since i saw it was missing so if i were to start it with the clutch pressed, the transmission wouldnt spin at all, right? and also if anyone would happen to know if there are another drain plugs off of any other trannys that would be compatible with the r380, that'd be great! Thanks
 

·
Premium Member
Joined
·
2,130 Posts
It might have gone 4 miles without a drain plug. I doubt 4k.
Although Prins did finish a Dakar race a few years back with an R380 that had lost fluid. First, 2nd, and 3rd had failed. They crossed the finish line with just 4th and 5th.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #5
No way it went 4,000 miles without fluid. Are you sure it isn't the bell housing wading plug that is missing? Post up a photo.
it was definitely the drain plug, down and to the left of the torx fill plug. it finally came in the mail this morning, after a flush and a fill it wont take second above 15km now
 
1 - 7 of 7 Posts
Top