Defender Source Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
154 Posts
Discussion Starter #1
I noticed tonight that when I depress the brake pedal my parking lights and my brake lights turn on. Intermittently it seems like the brake lights will start working as they should - only when the pedal is depressed. I verified that the ground on the battery is good, clean and tight.

The issue presented itself when I installed leds around the truck. I thought they might be the culprit so I changed back to incandescent bulbs and the issue above still persists.

What am I missing? Is it the brake pedal switch?
 

·
Super Moderator
Joined
·
13,008 Posts
Most likely a bad ground at one of the lights. It feeds power back through the ground via the parking lights as they share a ground connection. Check the grounds at the rear lights first and make sure they are well connected to the body.
 

·
Registered
Joined
·
154 Posts
Discussion Starter #4
Thanks. I'll give it a shot.

Would you recommend just making a new ground? I quickly tried to get the old ring terminal and ground screw out, but it is pretty .
 

·
Premium Member
Joined
·
5,394 Posts
Nothing wrong with a new ground. When I installed new VDO gauges I made a new ground with thicker wire and new fittings just to be sure.
 

·
Premium Member
Joined
·
6,201 Posts
When I hit my turn signal (in either direction) my trailer light on the dash illuminates briefly. I wonder if this is the same issue, or perhaps just normal, since I've only driven the one D.
 

·
Premium Member
Joined
·
6,201 Posts
Yup. That's what it does. Always thought it was strange to light up just the once so I thought something was a miss. When towing, it would blink as you described, so figured it was fine and maybe just a bit glitchy.
 

·
Registered
Joined
·
154 Posts
Discussion Starter #10
Grounds tested good. Also, I noticed when I turn on the parking lights via the switch my brake lights come on full blast.:facepalm:
 
1 - 10 of 10 Posts
Top