Defender Source Forum banner

1 - 6 of 6 Posts

·
Premium Member
Joined
·
804 Posts
Discussion Starter #1
300 tdi, I have replaced the ignition switch 3 times, it works for several months and then it won't start again, my question is, am I getting bad switches or could it be an electrical problem causing the switch to go bad,
 

·
Premium Member
Joined
·
804 Posts
Discussion Starter #3
No, I'm not sure, but I replaced the starter about a year ago, I'm on my 3rd ignition switch, I'm a novice on on these things ,
 

·
Premium Member
Joined
·
10,283 Posts
It sounds like your are burning the contacts on the start position.
It also sounds like you hooked the start position on the starter switch straight to the starter solenoid.
If this is true, then hooking a rely between the IG switch starter position and the starter solenoid would prevent the contacts from getting burned provided you hook the relay up as follows:

86 (+) from IG SW start position (white with red)
85 (-) Negative ground (black)
30 (+) from Battery (brown)
87 (+) to starter solenoid start position (white with red)
 

·
Premium Member
Joined
·
8,968 Posts
I've had issues with Ignition Switches...replaced it a couple of times, but mine seem to at least last a year or two. But then they de-laminate and the back of the switch starts to come off. Got sick of it the last time (just the other month) as I was leaving on a wheeling trip in literally a few hours. Rigged up a push-button Carling start and have actually been loving it!
 
1 - 6 of 6 Posts
Top