Defender Source Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
682 Posts
Discussion Starter #1
I'm hoping this is a rather straightforward question. After upgrading my 300tdi to a plastic tank and appropriate sender I need to find the appropriate female plug to wire into my loom that plugs into the sender.
Does anyone know if this style plug is used on any North American models, or what it's actually called so I can try and order one somewhere?

Thanks in advance

Will
 

Attachments

·
Registered
Joined
·
682 Posts
Discussion Starter #3
Looking at that I think your best option would be to get a 6" pigtail from a breakers in the UK, unless it's used on the D1/D2 ?
I was kind of thinking there might be a remote possibility a D1/D2 might be the same... maybe someone will know.

If not any suggestions of a non-shady breaker who would be willing to ship such a small item to Canada?
 

·
Registered
Joined
·
682 Posts
Discussion Starter #5

·
Premium Member
Joined
·
1,257 Posts
So what are you doing to get the correct wire leads & fittings for the Econoseal socket?

My concern is for if/when the leads could possibly rust out & need replacing.
 

·
Premium Member
Joined
·
1,568 Posts
That remains to be seen. I'll post back up once I've figured something out.
Digi-key stock TE Connectivity parts :

Female pins for 16-20g wire :
171662-1 TE Connectivity AMP Connectors | Connectors, Interconnects | DigiKey

Silicon seals:
900324-4 TE Connectivity AMP Connectors | Connectors, Interconnects | DigiKey

4 way housing:
174257-2 TE Connectivity AMP Connectors | Connectors, Interconnects | DigiKey

Hope that helps.... and you'll not get stung import duty :thumb:
 

·
Registered
Joined
·
682 Posts
Discussion Starter #10


Well rookie mistake not getting those, guess I'm ordering from them again. At least shipping is cheap and fast. Thanks for the links!
 

·
Premium Member
Joined
·
1,568 Posts
Well rookie mistake not getting those, guess I'm ordering from them again. At least shipping is cheap and fast. Thanks for the links!
Your not the only one that's done that.... I mis-ordered the terminals for my fuse box from VWP in the UK.... cost me twice in shipping.... Doh :facepalm:
 
1 - 11 of 11 Posts
Top