Defender Source Forum banner
1 - 13 of 13 Posts

·
Premium Member
Joined
·
157 Posts
Discussion Starter · #1 ·
For Sale $3500 OBO -

I’m doing a Cummins swap and selling the existing drivetrain from my 1991 ROW D90. I imported the car about two years ago from Spain. It’s got 133,000 Km (83,000 miles) on the odometer, service history unknown before the last two years/3,000 miles.

It’s a 200TDI with LT77 gearbox and and LT230 transfer case. Everything front to back is included: radiator, intercoooler, airbox, injection pump, new electric fan, and all related parts I don't need.

Motor runs and drives very nicely. Cruises on the highway at 65mph with no problems. Within the last 500-1000 miles:

New head gasket, new injectors, new timing belt and pulley, new electric fan, new water pump, new hoses, most new belts, new thermostat, new high output alternator, new high torque starter, new transfer case intermediate seal, new front and rear output shaft seals and mudguards, new diff lock switch, new reverse switch, remove and reseal the oil sump, new Slickshift gear change, etc.

There is a small coolant leak on the back of the thermostat housing, and it seems to be leaking a little from the injection pump but I can’t find (haven't really looked) exactly where. There is another small leak from the gearbox drain plug which I think a new crush washer would fix. I replaced the seals on the rear output shaft but I think there is still a little leak into the transmission brake. None of these leaks actual leave spots on my floor, just some fluids on the motor.

The coolant gauge shows it running a little hot (see video) but I think it’s just the ground on the gauge. It gets to that temp level and stays there forever, even on the hottest days driving in town.

The motor is still in the truck and being driven, but will be puled in the next week. I’m in the Denver area and can help with delivery/packing or you can pick it up.





 

·
Premium Member
Joined
·
11,175 Posts
Videos are not operational.
Try posting to YouTube and just adding the URL here via the link feature when you make a post.
 

·
Registered
Joined
·
32 Posts
Hmm. The YouTube video links are what I pasted in and they seem to be showing fine for me... Here are the links again:


Thanks for the heads up.
You might need to make the videos public?

When did you order your R2.8?
 

·
Premium Member
Joined
·
157 Posts
Discussion Starter · #5 ·
You might need to make the videos public?
@dkemm for the win. I forgot to mark the videos as Public. Fixed now...

I found a "used" R2.8 with only a few hundred miles on it. It came from a custom builder whose client decided on a Gen 5 LT motor after the Cummins was installed and tested. I got the complete powertrain with Tremec five speed, cooling, etc... I'm also putting in a new galvanized chassis (thanks insurance!)
 

·
Premium Member
Joined
·
157 Posts
Discussion Starter · #13 ·
Sorry I forgot to update this, but the motor and drivetrain has sold.
 
1 - 13 of 13 Posts
Top