Defender Source Forum banner

1 - 20 of 51 Posts

·
Registered
Joined
·
73 Posts
Discussion Starter #1
Hi everybody! please help
i got 1994 land rover defender
it is shuts off while i was driving and then i was able to start it up in about 45 min.
is anyone have any idea what is going on?
it is happened to me already 2nd time
thank you
 

·
Registered
Joined
·
371 Posts
Sergey,

Welcome to the board and welcome to the often bewildering world of Land Rover ownership. There are some very experienced folks on this board who can help, but they will need details about your problem. You can also do a little troubleshooting first. When it quits, does it still have spark? Can you hear the fuel pump when you turn the key on? Does it sputter to a stop or just quit all together?

Try those few things first, then add any additional info you can to help the folks help you. Good luck.
 

·
Premium Member
Joined
·
458 Posts
Ignition amplifier is on it's way out. Buy the relocation kit and you won't have this issue again…@ least not coming from this part. Good luck!
 

·
Premium Member
Joined
·
16,553 Posts
Hi everybody! please help
i got 1994 land rover defender
it is shuts off while i was driving and then i was able to start it up in about 45 min.
is anyone have any idea what is going on?
it is happened to me already 2nd time
thank you
Also remove your IACV (it's at the rear of the plenum on the passenger side...white arrow in the pic) and hit it with some carb cleaner spray and re-install. It may just be sticky from carbon build-up.
 

Attachments

·
Registered
Joined
·
73 Posts
Discussion Starter #6
i am really appreciate your advice and definitely going to try that
thank you so much
I will reply with feed back:)
 

·
Premium Member
Joined
·
3,844 Posts
I second the amplifier. The ignition switch can also be at fault and has shut off while I drove before-- that is super easy to diagnose when you can't restart by checking if your coil is getting 12v. But if you haven't relocated amplifier (or swapped to Mallory distributor), then that is most likely. Even if it isn't, you should still relocate it.

The IACV really only affects start up and idle at stopped-- if your issue is while driving then not as likely a cause. Super easy to clean if dirty, though, and can affect start up.
 

·
Registered
Joined
·
73 Posts
Discussion Starter #8
i didn't do anything yet... truck is just standing in my garage
It is idle for approximately 3 min , then shuts off
i can start it right away and it runs for another minute, then shuts of
i can start it again and it shuts of right away
 

·
Registered
Joined
·
73 Posts
Discussion Starter #9
i didn't do anything yet... truck is just standing in my garage It is idle for approximately 3 min , then shuts off i can start it right away and it runs for another minute, then shuts of i can start it again and it shuts of right away

image-596484473.jpg





image-2467975639.jpg



image-1865672615.jpg



image-2101425153.jpg

here is my ignition set up
please advise? how do I connect ignition amplifier
i just ordered ignition amplifier relocation kit
thank you
 

·
Registered
Joined
·
73 Posts
Discussion Starter #10
Hi folks !
i just ordered ignition amplifier relocation kit
and now i am looking at my distributor-ignition set up and i am getting pretty confused
1 i cant really see ignition amplifier
here is my ignition set up

image-1012965498.jpg



image-3197995775.jpg

please advise me
may be I don't even have this thing IA on my truck
 

·
Premium Member
Joined
·
6,129 Posts
Someone has previously replaced it with a Mallory setup. Josh had the same problems that caused him to stall out for years. if you are experiencing the same issue it was because the coil sends a 12v signal to the ECU on your setup and the standard coil sends 9v.

I created a workaround which used two resistor chicklets in series to lower the current to the ECU which appears to have fixed it.

one me and I can walk you through it.
 

·
Registered
Joined
·
73 Posts
Discussion Starter #12
Thanks for your reply and please walk me trough,
the ignition amp will arrive tomorrow or Wednesday
Should i get some other parts?
thanks again for you time
 

·
Premium Member
Joined
·
16,553 Posts
take that little black mallory box out of there with the 3 wires in and out of it. Mine was bad and it's just one more thing to break.
 

·
Premium Member
Joined
·
6,129 Posts
Thanks for your reply and please walk me trough,
the ignition amp will arrive tomorrow or Wednesday
Should i get some other parts?
thanks again for you time
The standard amp is no longer used on your vehicle ...
 

·
Registered
Joined
·
73 Posts
Discussion Starter #16
I just disconnected small mallory box
the truck acting the same running for couple of minutes and then shuts of

I noticed that white box getting pretty hot fast

image-4041117838.jpg
 

·
Premium Member
Joined
·
6,129 Posts
Take this one step at a time to avoid getting confused about what works and what doesn't.

Get an led test light and test the signal in the highlighted wire. It will flash every time the engine sparks. The signal tells the ECU that the engine is running and therefore it can turn on the fuel pump.

If you have no signal here then the ECU wont turn on the fuel pump.
 

Attachments

·
Registered
Joined
·
73 Posts
Discussion Starter #18
should i cancel my order of ignition amplifier relocation kit and just order mallory ignition coil?
which one should i get ?
thank you

------ Follow up post added October 5th, 2015 01:06 PM ------

could you please send me a few pictures of how it is done on yours truck
 

·
Registered
Joined
·
73 Posts
Discussion Starter #20
none of I know about
i got this truck about a year ago and i dont know what previous owners had there
thank you

------ Follow up post added October 5th, 2015 01:25 PM ------

what is the part number for ignition coil and where can i get it
 
1 - 20 of 51 Posts
Top