Defender Source

Defender Source (http://www.defendersource.com/forum/)
-   Defender Technical Discussions (http://www.defendersource.com/forum/f6/)
-   -   Ticking noise. Oil pump? (http://www.defendersource.com/forum/f6/ticking-noise-oil-pump-21990.html)

ini88 September 27th, 2009 08:50 PM

Ticking noise. Oil pump?
 
I started getting a ticking noise a little bit ago. Its in the engine bay and seems to be passenger side. Its not exhaust because i felt around and didn't feel air and it is more mechanical sounding than air an escaping noise. It ticks after the engine is running at normal temp. Im running thin 5-30 oil when I usually run thick 20-50. could the oil pump be making this noise? oil light is not on.

evilfij September 27th, 2009 09:01 PM

rocker shaft, lifter are more likely

ini88 September 27th, 2009 09:08 PM

Quote:

Originally Posted by evilfij
rocker shaft, lifter are more likely

danmit! I was thinking a lifter or sticky valve too. I put some valve cleaner stuff in the engine and obviously it didn't work, but my hopes on a bottle of magic were low to begin with.

evilfij September 28th, 2009 09:59 AM

Take off the valve cover, you can probably figure out which rocker it is. Lifters chug at start up, rockers tick in my experience.

sherpamike September 28th, 2009 02:29 PM

Mine has developed a similar ticking. How difficult is it to replace rockers?

evilfij September 28th, 2009 02:39 PM

Quote:

Originally Posted by sherpamike
Mine has developed a similar ticking. How difficult is it to replace rockers?

Very easy to do. 15 minutes for passenger side, half-hour tops on the driver's side (pretty sure you have to pull the intake cover for that but you might be able to get the valve cover off without pulling it).

landrovered September 28th, 2009 02:45 PM

Personally, I would not run 5 wt oil, my engine likes 10-15 wt. Change the oil, I will bet that the ticking goes away.

sherpamike September 28th, 2009 03:24 PM

Mine runs 20-50 dino oil... I need to check the exhaust to rule that out. I haven't had much time lately to tinker but maybe I can get back in the garage to check things out soon.

evilfij September 28th, 2009 03:31 PM

Quote:

Originally Posted by landrovered
Personally, I would not run 5 wt oil, my engine likes 10-15 wt. Change the oil, I will bet that the ticking goes away.


I take the opposite tack. I use 0w40 or 5w40 synthetic. Rocker wear is usually caused by build up and or poor oiling from too heavy of an oil/and/or running low on oil and/or lack of changes.

landrovered September 28th, 2009 03:40 PM

I run synthetic as well but since I was not the owner for the first 80k miles of my 110s career, I use 10-40 Mobile 1 extended in my motor and since my RRC has 220k miles I run 10-50 Mobile 1 synthetic in it.

It has been my experience that lower weight oils like 0 & 5 will cause valve ticking in rover V8s.

ini88 September 28th, 2009 03:47 PM

I use a 5-30 Mobil 1 in the winter and a 20-50 Amsoil in the summer. I changed the oil to 5-30 before I did a long drive up to Nova Scotia and back and since then I noticed the ticking. going to change the oil to the thick shit tonight and see how it goes.

Campbell November 25th, 2009 06:12 PM

How did you make out with the tick?


All times are GMT -5. The time now is 11:42 PM.

Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2018 DragonByte Technologies Ltd.