yet more electical problems - Defender Source
Defender Source  

Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions

Join the Defender Source Community Today

Thread Tools
Old January 7th, 2010, 12:54 PM
Status: Offline
robert hall
95 d-90sw
Join Date: May 2008
Location: anchorage, ak
Posts: 76
yet more electical problems

i took my 95 d-90 to local dealer last fall for 60K service and also had them put in a heated windshield and wire up my new heated seats. after that i noticed air conditioner and rear wiper no longer work, they also hooked up the heated seats backwards left to right and vice versa and the lights on the switches only work intermittently. truck also started leaking into interior dash area on passenger side after this. i asked about this on this board and was reassured this didnt come from removing the old windshield but the timing sure is curious to me. thought i could live with these and deal with them later myself as i certainly dont want to take my truck back to that shop. now truck has started dying at stop lights, tachometer doesnt work and check engine light comes on = error code 68- road speed sensor. after researching here one possiblity seems to be a short somewhere in the electrical system for the tach/speed sensor problem. now am wondering if water in dash is responsible for tach/sensor and has also shorted out other things like AC and rear wiper. my electrical skills are on the low end to say the least. i havent been able to find a mechanic up here too excited about taking on an electrical project in a defender. any ideas about if i am on right track and where short might be that would take out all these systems? anyone happen to know any rover mechanics in alaska? Keith- is the previous owners lifetime warranty still in effect?

Reply With Quote
Old January 7th, 2010, 04:30 PM
woldd90's Avatar
Status: Offline
1997 D90 ST #1444
Site Team
Join Date: Aug 2005
Location: Georgia
Posts: 5,182
Sounds like a short or they tapped into a wire that they shouldn't have... Start by disconnecting the windshield and seat heaters, see if that fixes anything.

I would take it back to them and have them fix it correctly, at no charge. Or, they should credit back part of your bill. If not, call your credit card company and fight the charges.

Reply With Quote

Lower Navigation
Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
97 SW rear door electical problems! Hammertime Defender Technical Discussions 1 September 4th, 2007 07:51 PM
94 shifting problems jstrong98 Defender Technical Discussions 6 January 26th, 2006 03:06 PM
Server Connection Problems chrisvonc Community News & Announcements 1 July 25th, 2004 09:22 PM
reciever electrical problems yellowrover Defender Technical Discussions 7 March 17th, 2004 05:13 PM
Ignition problems boshea Defender Technical Discussions 7 October 7th, 2003 07:48 AM

All times are GMT -5. The time now is 10:42 PM.