Wipers - Defender Source
Defender Source  

Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions


Reply
 
Thread Tools
  #1  
Old April 21st, 2016, 06:31 AM
1of40's Avatar
1of40
Status: Offline
1of40
NAS 97SW & 83 One Ten Tdi
Member
 
Join Date: Dec 2003
Location: Potomac Falls & Wintergreen, Virginia
Posts: 5,545
Registry
Wipers

Any similar experiences or know what's going on here?

NAS wiper arms in intermittent mode moving very slow, almost not making it back to starting position. Working at normal speed however in non-intermittent mode.

Searched for similar issue but didn't find anything on point. Please forward a link if you are aware of prior posts.
__________________

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old April 21st, 2016, 06:42 AM
Nomar's Avatar
Nomar
Status: Offline
Jeff B
RR HNTR,RR LWB Tdi
Member
 
Join Date: Aug 2004
Location: Central,Virginia
Posts: 4,012
Registry
Failing park switch?

Search function blows....


.
__________________


Real Rovers have round headlights!
Rent my
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
!
Just a few miles from 4x4 access!
Reply With Quote
  #3  
Old April 21st, 2016, 06:50 AM
1of40's Avatar
1of40
Status: Offline
1of40
NAS 97SW & 83 One Ten Tdi
Member
 
Join Date: Dec 2003
Location: Potomac Falls & Wintergreen, Virginia
Posts: 5,545
Registry
Quote:
Originally Posted by Nomar View Post
Failing park switch? Search function blows.... .
Thanks, found this nice piece.

http://www.defendersource.com/forum/...ent-14243.html
__________________

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Reply With Quote
Sponsored Links
Advertisement
 
  #4  
Old April 21st, 2016, 07:11 AM
leastonce's Avatar
leastonce
Status: Offline
Jason England
D-90 White 95 SW #65
Site Team
 
Join Date: Jul 2009
Location: NYC
Posts: 6,074
Registry
Quote:
Originally Posted by Nomar View Post
Failing park switch? Search function blows.... .
Search was improved just yesterday ... It's a lot better. Or it would be better if people could spell ...
__________________
Quote:
Soapy water / KY jelly, etc. is is basically a must. Yes, good idea to remove trim panels - only takes 5 more minutes to do so.
Car Camping Collective founding member and Chief Executive Officer
Cat Camping Collective founding member and Chief Executive Officer
Reply With Quote
  #5  
Old September 30th, 2016, 09:52 AM
olsin77's Avatar
olsin77
Status: Offline
Olsin Petro
1999/Defender 110
Member
 
Join Date: Dec 2015
Location: Tirana, ALBANIA
Posts: 86
Hi everyone,
My wipers stop where they should but i have another issue,
My wipers don't seam to go up until close to the end of the windscreen and they leave quite a bit of screen without wiping, about 4 inches (11cm).
anyone has an idea of this?.
Lately i installed two new arms, spindles and the endless screw.
Any ideas?
Thank you,





Sent from my HTC_M910x using Tapatalk
Reply With Quote
  #6  
Old October 2nd, 2016, 08:23 AM
Capt Milks's Avatar
Capt Milks
Status: Offline
Mike
Defender V-8, Defender 2.25
Member
 
Join Date: Oct 2004
Location: United States
Posts: 1,794
Clay ..if they are moving slow at first but pick up with water on the windshield, less resistance and with speed, on high, you might just have sticky wheel boxes. Be careful in what grease you use as it needs to be the less resistance type. My guess is that they are just funked up and need to be cleaned. The wheel boxes could be warn however and need replacement.
__________________
Land Rover 110
Reply With Quote
  #7  
Old October 2nd, 2016, 11:08 AM
olsin77's Avatar
olsin77
Status: Offline
Olsin Petro
1999/Defender 110
Member
 
Join Date: Dec 2015
Location: Tirana, ALBANIA
Posts: 86
Quote:
Originally Posted by Capt Milks View Post
Clay ..if they are moving slow at first but pick up with water on the windshield, less resistance and with speed, on high, you might just have sticky wheel boxes. Be careful in what grease you use as it needs to be the less resistance type. My guess is that they are just funked up and need to be cleaned. The wheel boxes could be warn however and need replacement.
Hi,
They are new also.
And they have same speed while moving. But of course when is raining and they are worked a little bit they move better, still they don't go far in up position.


Sent from my HTC_M910x using Tapatalk
Reply With Quote
Reply

Lower Navigation
Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
wipers? mattdh Defender Technical Discussions 19 June 4th, 2013 11:57 AM
wipers overrun artm Defender Technical Discussions 18 February 26th, 2009 12:32 AM
Any 3rd party windshield wipers? cdnpaul Defender Technical Discussions 36 April 27th, 2008 08:36 PM
Windscreen wipers TDI Guy Defender Technical Discussions 22 December 2nd, 2004 11:41 AM
Windshield wipers not functioning properly cdnpaul Defender Technical Discussions 1 November 10th, 2003 01:52 PM


All times are GMT -5. The time now is 03:10 AM.


Copyright