Wiper Motor not working - Defender Source
Defender Source  

Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions


Reply
 
Thread Tools
  #1  
Old April 3rd, 2012, 09:53 PM
RiftRover's Avatar
RiftRover
Status: Offline
Mike Barnett
110
Member
 
Join Date: Apr 2009
Location: Little Rock, Arkansas
Posts: 813
Wiper Motor not working

So my wiper motor doesn't work and I'm trying to avoid dropping the coin for a brand new one. I noticed there are a couple of parts available like the brush assembly and something called the park switch. Anybody have any experience with repairing these things? Or am I doomed to spend nearly $300 on a new one?
Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old April 4th, 2012, 12:26 AM
Turbofan's Avatar
Turbofan
Status: Offline
Ethan
'73 SIII/ D90 Hybrid
Member
 
Join Date: Jun 2008
Location: Westport, CT
Posts: 139
I've never seen a brush kit for one of these, but that doesn't mean they don't exist. The park switch is really nothing more than a contact switch; it allows the motor to keep running until it sees a certain position (the switch), then it shuts off. is yours completely dead? Did you check the switch? $300 seems really steep for a new one. Are there any old school electric motor rebuilders around you (or guys that will rebuild starters or alternators)? I bet it could be rebuilt for less than a new one. If you get stuck, I think I have a couple used ones in my garage. I'd have to check the condition of them though.
Reply With Quote
Reply

Lower Navigation
Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions

Tags
motor

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
What makes the Rear Wiper park? COSteve Defender Technical Discussions 10 March 6th, 2007 04:40 PM
Rear Wiper - Anyone Please Kimos Defender Technical Discussions 14 November 8th, 2005 02:10 PM
Locating the rear wiper pepstein Defender Technical Discussions 0 April 2nd, 2005 09:56 AM
Wiper Blades going haywire... arbik Defender Technical Discussions 4 February 22nd, 2005 11:07 PM
bulkhead and wiper stud fitting problem mattdh Defender Technical Discussions 3 April 2nd, 2004 09:42 AM


All times are GMT -5. The time now is 04:09 PM.


Copyright