winch help???? - Defender Source
Defender Source  

Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions


Reply
 
Thread Tools
  #1  
Old March 4th, 2004, 12:53 AM
ccrover
Status: Offline
craig crawford
1995 d90 ST red
Member
 
Join Date: Oct 2003
Location: studio city, ca
Posts: 24
Unhappy winch help????

help please?? i have a arb bull bar and warn xd9000 setup...

i just installed a new control box wired it up and turned on engine and plugged in remote control to winch.... pushed up and the winch worked... hurrray.... pushed down and a quick spark and then nothing.... oh boy what did i do ....

i forgot to wire the hidden power for the reeling in (whichever is pushing down on the remote)... it is concealed by the bumper.... so i wired that up to the positive terminal and all was done....

but now with the control all i get is clicking no turning of the winch.... did i blow some sort of fuse?? or did i do worse to my winch???

help please its my first time wiring this winch up too...

thank you in advance

-craig
Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old March 4th, 2004, 09:16 AM
Mike Hippert's Avatar
Mike Hippert
Status: Offline
D-90Slut/Stalker,SNLPres
94 D-90 Grinding Rover
Member
 
Join Date: Sep 2003
Location: Manchester NH USA
Posts: 4,789
Warn is good about customer service, I would give them a call as you may have done some damage. I would think they would be more then willing to help out.
__________________
Don't forget to
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
first then ask questions later! The loose nut behind the wheel
Reply With Quote
  #3  
Old March 4th, 2004, 02:18 PM
Weldon's Avatar
Weldon
Status: Offline
Weldon Pundt
"95" D-90
Member
 
Join Date: Oct 2003
Location: Charleston, SC
Posts: 266
Careful with the phrase "help with winch"!!!
__________________
Thanks
Weldon
Reply With Quote
Sponsored Links
Advertisement
 
  #4  
Old March 4th, 2004, 07:51 PM
ccrover
Status: Offline
craig crawford
1995 d90 ST red
Member
 
Join Date: Oct 2003
Location: studio city, ca
Posts: 24
hahah... yes i see my phrasing now! all is good that second wire was supposed to go to the negative battery terminal...

i guess the first time i started it up, it must of self grounded and then shut off...

luckily no damage and it is running fine...

thank you for any feed back.

-craig
Reply With Quote
Reply

Lower Navigation
Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions

Tags
winch

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
used winch now engine runs weird cpk Defender Technical Discussions 6 March 5th, 2006 04:03 AM
Winch Mount bjenk Defender Technical Discussions 6 November 27th, 2005 08:00 PM
Safari Gard winch bumper and winch m016324 For Sale - Parts 3 September 20th, 2005 09:52 PM
D-90 Winch Bumper Capt Milks For Sale - Parts 0 August 27th, 2005 08:35 AM
WARN 8274-50 Winch, THE ULTIMATE!!! RedRhinoProducts For Sale - Parts 0 September 28th, 2004 08:18 AM


All times are GMT -5. The time now is 11:50 PM.


Copyright