Will not start...PLEASE HELP!!! O2s??? - Defender Source
Defender Source  

Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions


Reply
 
Thread Tools
  #1  
Old June 12th, 2010, 04:28 PM
tebby's Avatar
tebby
Status: Online
Justin Tebbenkamp
95 D-90 ST
Member
 
Join Date: May 2008
Location: Blacksburg, VA, USA
Posts: 274
Will not start...PLEASE HELP!!! O2s???

95 with approx 99k. I've been delaying maintenance due to an upcoming move and starting a business. Coulpe of known issues: 1. I'm leaking antifreeze and I know I have to replace a water pump...gonna replace with geniune pump and all my belts. 2. Since I purchased the vehicle it's been running rich...tail pipe is super black. 3. I have a huge hole in my muffler that's developed over the past several months. 4. Running very rough...sometimes stalling when I come to a stop.

Here's where I need help!!! I usually drive everyday...haven't driven it for a couple of days. Drove it for about 5 minutes this am...stalls and dies. Won't restart!!! It's turned over and fired a couple of times (very rough idle)...when I gave it gas it died. I put some sea foam in the gas tank (praying) and now it won't fire at all. I'm assuming it's the O2 sensor(s)...does this sound right. All of the lights on my dash look normal....I don't think it's throwing any codes. I've also read that when the O2s go bad it can make the cats go bad---causing a blow out in the muffler (which I have). Where should I begin? The O2s...just the fronts or all four? The cats? Or both? I did a search and saw where Will has a decent deal on the O2s. thanks...justin....276-388-3689
Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old June 12th, 2010, 09:40 PM
evilfij's Avatar
evilfij
Status: Offline
evilfij
I have never seen a rover in person
Member
 
Join Date: Oct 2003
Location: on the internet
Posts: 14,688
Sounds like it is flooded.

1. Try starting it foot to the floor on the gas pedal.
2. If that does not work, disconnect the MAF and try starting it with your foot to the floor.
3. make sure the water pump bearing has not siezed (my LWB did this and died--only time it was ever on a tow truck).

Report back. I PMed you my cell.

Ron

Ron
__________________
*not legal advice*
Reply With Quote
  #3  
Old June 12th, 2010, 09:55 PM
rover4x4's Avatar
rover4x4
Status: Offline
Phillip
1995 SW #487/500
Member
 
Join Date: Sep 2003
Location: The Old North State
Posts: 7,523
Registry
Youve only got two O2 sensors, have you looked at the spark plugs?
__________________
Poor gas mileage gets you to the best places on earth
Reply With Quote
Sponsored Links
Advertisement
 
  #4  
Old June 12th, 2010, 10:24 PM
evilfij's Avatar
evilfij
Status: Offline
evilfij
I have never seen a rover in person
Member
 
Join Date: Oct 2003
Location: on the internet
Posts: 14,688
*fingers crossed*
__________________
*not legal advice*
Reply With Quote
  #5  
Old June 13th, 2010, 11:45 AM
tebby's Avatar
tebby
Status: Online
Justin Tebbenkamp
95 D-90 ST
Member
 
Join Date: May 2008
Location: Blacksburg, VA, USA
Posts: 274
thanks ron!!!

Got it running!!! Thanks to Ron!!! I replaced the fuel pump relay under the pass seat...and it runs. I found a cross ref relay from advanced auto. Both the EFI & fuel pump relays are the same....THE FUNNY THING IS...I replaced both of them and it wouldn't start. I kept one of the orginal relays on the black harness (i think the EFI relay) and replaced the relay on the blue harness ( i think the fuel pump)...and it starts. I guess one of the relays I bought from advanced may be bad? Thanks again Ron!!! j
Reply With Quote
Reply

Lower Navigation
Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions

Tags
start

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Truck will not START ? Weldon Defender Technical Discussions 28 December 15th, 2005 12:58 PM
HELP 94 d90 will not start ripp2002 Defender Technical Discussions 64 August 25th, 2005 08:43 AM
95 won't start, possible fuel priming issue? jcasteel Defender Technical Discussions 1 March 15th, 2005 09:45 AM
Rats! Now my D90 won't start. No power to fuel pump jcasteel Defender Technical Discussions 8 March 15th, 2005 09:42 AM
Ignition Relocation = No Start...Help JRowe Defender Technical Discussions 5 March 8th, 2004 12:45 PM


All times are GMT -5. The time now is 05:57 AM.


Copyright