whats wrong? - Defender Source
Defender Source  

Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions


Reply
 
Thread Tools
  #1  
Old May 3rd, 2004, 06:20 PM
jperakis
Status: Offline
James Perakis
94 ST
Member
 
Join Date: Sep 2003
Location: SF Bay Area
Posts: 508
whats wrong?

i was on the freeway today and whenever i hit the accelerator it was as if i had the clutch in. It just reved and reved!!! the only gear that halfway worked was 1st but that only worked up to about 1500 rpm.
I just had my cluth master cylinder replaced so im hoping that it was just faulty repair work.
Is there anything else that it could be?

thanks a lot,
James Perakis
Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old May 3rd, 2004, 07:59 PM
TDI Guy's Avatar
TDI Guy
Status: Offline
Randy
2015 LR4
D-90 Source Vendor
 
Join Date: Sep 2003
Location: NJ
Posts: 4,573
Registry
sounds like the clutch is slipping. how many miles on the truck and the clutch.. Or a rear mail seal leaking on the clutch.
__________________
Legend in My Own Mind.
Reply With Quote
  #3  
Old May 3rd, 2004, 08:28 PM
jperakis
Status: Offline
James Perakis
94 ST
Member
 
Join Date: Sep 2003
Location: SF Bay Area
Posts: 508
125K on the truck... and the clutch was replaced last summer in july. so it cant have more then 8-9K on it at the most.

if the clutch is infact slipping what do i do?
__________________
remember two things...
Reply With Quote
Sponsored Links
Advertisement
 
  #4  
Old May 3rd, 2004, 09:06 PM
Buckon37s's Avatar
Buckon37s
Status: Offline
Buck
Re-Fendered 90
Member
 
Join Date: Oct 2003
Location: Temecula, CA, USA
Posts: 3,376
James, can you shift the truck?
__________________
2009 King of the Hammers

BUCK Wild Racing
Driver: Me
Co-driver: Pat Quirk
Team 911

Rover Tracks
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
PSC
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
DJ Safety
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
West Coast Rovers
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Reel Driveline
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Made it further than half of the other guys, but the Hammers won.
Reply With Quote
  #5  
Old May 3rd, 2004, 09:23 PM
jperakis
Status: Offline
James Perakis
94 ST
Member
 
Join Date: Sep 2003
Location: SF Bay Area
Posts: 508
yea it shifts no problem, and the clutch feels fine.
__________________
remember two things...
Reply With Quote
  #6  
Old May 3rd, 2004, 09:28 PM
Buckon37s's Avatar
Buckon37s
Status: Offline
Buck
Re-Fendered 90
Member
 
Join Date: Oct 2003
Location: Temecula, CA, USA
Posts: 3,376
Possibly the throwout bearing. The only thing I can guess is the clutch is no longer engaging the flywheel. Might need a new throwout bearing when we swap the tranny, but I bet the new tranny will come with a new one also.
__________________
2009 King of the Hammers

BUCK Wild Racing
Driver: Me
Co-driver: Pat Quirk
Team 911

Rover Tracks
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
PSC
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
DJ Safety
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
West Coast Rovers
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Reel Driveline
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Made it further than half of the other guys, but the Hammers won.
Reply With Quote
  #7  
Old May 3rd, 2004, 10:18 PM
TDI Guy's Avatar
TDI Guy
Status: Offline
Randy
2015 LR4
D-90 Source Vendor
 
Join Date: Sep 2003
Location: NJ
Posts: 4,573
Registry
just for the hell of it, does it do it when you have the diff locked also?
__________________
Legend in My Own Mind.
Reply With Quote
  #8  
Old May 4th, 2004, 11:52 PM
Tom Fitzgerald
Status: Offline
Tom Fitzgerald
97 D90 SW
Member
 
Join Date: Oct 2003
Location: Charlottesville, VA area
Posts: 23
You might make sure the slave rod is adjusted properly. Sounds like it may be too long and doesn't allow the fork to return far enough to allow the pressure plate to fully 'pinch' the disk. Plus it follows the "last part touched" methodology. Worth a look. Good luck.

Tom
Reply With Quote
  #9  
Old May 5th, 2004, 01:13 AM
jperakis
Status: Offline
James Perakis
94 ST
Member
 
Join Date: Sep 2003
Location: SF Bay Area
Posts: 508
so miraculously the 90 seems to have fixed itself, for the time being at least. I just fiddled around with the Tcase and everything is now fine ( knock on wood)
but knowing my truck, the problem will come back very soon.
dave, i thought it could have been the throw out bearing as well but i remember last time it went out there was a horrible squeeling noise whenever the clutch was engaged.
Tom i will be sure to check out the rod when i have the tranny dropped next month

thanks to all for the advice!
__________________
remember two things...
Reply With Quote
  #10  
Old May 5th, 2004, 09:25 PM
evilfij's Avatar
evilfij
Status: Offline
evilfij
I have never seen a rover in person
Member
 
Join Date: Oct 2003
Location: on the internet
Posts: 14,688
If a MC or SC is misadjusted they will build pressure and disengage the clutch.

Make sure there is the correct amount of free play on the MC pedal, I want to say it is 1/2in-3/4in but IIRC it is in metric and I do not do metric.

Ron
__________________
*not legal advice*
Reply With Quote
Reply

Lower Navigation
Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Damn! Cannot figure out what is wrong with the lights! solihul Defender Technical Discussions 11 October 26th, 2017 07:04 PM
Something Wrong With The Front End? The Wizard Defender Technical Discussions 13 October 4th, 2006 11:51 PM
Fuel pump relay issues?-- wrong message board..ignore! chuff Misc. Chit-Chat 0 August 28th, 2006 07:29 PM
Whats wrong with this picture? chrisvonc Misc. Chit-Chat 3 April 8th, 2004 09:56 PM


All times are GMT -5. The time now is 04:39 AM.


Copyright