Turn Signals (rears work, fronts don't) - Defender Source
Defender Source  

Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions


Reply
 
Thread Tools
  #1  
Old September 2nd, 2006, 10:27 AM
cmcarp
Status: Offline
Craig M. Carpenter
2000 Discovery
Member
 
Join Date: Feb 2004
Location: Indiana
Posts: 2
Turn Signals (rears work, fronts don't)

'94 D-90. All running lights work. Rears flash. Fronts do not. Getting fast flash from the flashing unit. Is there a ground I should be checking?

Thanks in advance for any tips.
Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old September 5th, 2006, 02:54 PM
Mike Hippert's Avatar
Mike Hippert
Status: Offline
D-90Slut/Stalker,SNLPres
94 D-90 Grinding Rover
Member
 
Join Date: Sep 2003
Location: Manchester NH USA
Posts: 4,789
Sometimes banging on the front wing makes them work. Otherwise fallow the wires back and check all connections.
__________________
Don't forget to
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
first then ask questions later! The loose nut behind the wheel
Reply With Quote
  #3  
Old September 5th, 2006, 04:55 PM
cmcarp
Status: Offline
Craig M. Carpenter
2000 Discovery
Member
 
Join Date: Feb 2004
Location: Indiana
Posts: 2
Thanks. Makes sense. It actually started happening after one of the lenses got cracked. It has a SG front bumper, so the bottom running lights on the front of the wings are now serving as the turn indicators. I will chase down the grounds and see if this is the source of the problem.
Reply With Quote
Reply

Lower Navigation
Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions

Tags
signal

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Best way across the US Mike Hippert Defender Technical Discussions 173 April 29th, 2010 04:56 PM
Turn signals don't work cdb Defender Technical Discussions 4 April 30th, 2009 11:10 PM
turn signals and flashers not working draaronr Defender Technical Discussions 4 April 27th, 2008 10:19 PM
Turn signal dfscott Defender Technical Discussions 5 November 28th, 2005 09:54 PM
Relocating Turn Signals Doug_Paoletti Defender Technical Discussions 13 July 26th, 2005 11:49 AM


All times are GMT -5. The time now is 10:17 AM.


Copyright