turn signals and flashers not working - Defender Source
Defender Source  

Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions


Reply
 
Thread Tools
  #1  
Old April 25th, 2008, 08:40 PM
draaronr's Avatar
draaronr
Status: Offline
Here
LR3
Member
 
Join Date: Dec 2003
Location: nc USA
Posts: 1,799
turn signals and flashers not working

I did a search but didn't find exactly what I needed. Here it is hit the stick on the column to turn the turn signals on and nothing happens. Then hit the hazzard switch and nothing. Now hold down the hazzard switch and all 4 signals do the normal rate flash, as soon as you remove your finger the flashers stop.

Now it gets weird. I took out the seats and cleaned up the dash around the steering wheel and center console. (97 by the way) and started the truck up to move it and I thought what the hell I hit the stick and the blinkers on the drivers side came on, turn them on the passenger side and they came on, now the inside indicator wasn't lighting up but I could hear the rhythmic ticking of the blinker switch(or relays). So i turn them off, and hit the hazzard, holy shit it works and it the switch is lighting up but still not on the dash.

So I check the blinkers again, and son-of-a-bitch it's not working again, hit the hazzard and nothing.

What do I need to check, and what should I be looking for.
Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old April 27th, 2008, 08:14 AM
JBfoot's Avatar
JBfoot
Status: Offline
Joe Barefoot
'94 D90, '07 D110, '08 LR2, '09 D90
Member
 
Join Date: Aug 2007
Location: Cayman Islands
Posts: 85
The right and left turn signals are on seperate circuits. When you are having problems with both sides, think about where the circuits might come together. The hazard switch comes to mind first. From your description, my bet is that is where the problem is. Take it out and clean and inspect the contacts. The only other thing that I can think of is a trailer wiring harness. All of the turn indicators come in close proximity there. Good luck!
Reply With Quote
  #3  
Old April 27th, 2008, 08:31 AM
draaronr's Avatar
draaronr
Status: Offline
Here
LR3
Member
 
Join Date: Dec 2003
Location: nc USA
Posts: 1,799
I will try that in a few minutes, so if I don't have trailer wiring I can skip that?
Reply With Quote
Sponsored Links
Advertisement
 
  #4  
Old April 27th, 2008, 08:48 PM
draaronr's Avatar
draaronr
Status: Offline
Here
LR3
Member
 
Join Date: Dec 2003
Location: nc USA
Posts: 1,799
that fixed it, thanks Joe.
Reply With Quote
  #5  
Old April 27th, 2008, 10:19 PM
JBfoot's Avatar
JBfoot
Status: Offline
Joe Barefoot
'94 D90, '07 D110, '08 LR2, '09 D90
Member
 
Join Date: Aug 2007
Location: Cayman Islands
Posts: 85
Yea mon!
Reply With Quote
Reply

Lower Navigation
Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions

Tags
signal

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Turn signals don't work cdb Defender Technical Discussions 4 April 30th, 2009 11:10 PM
Turn signal clicking like mad Dredd Defender Technical Discussions 8 February 24th, 2009 01:41 PM


All times are GMT -5. The time now is 12:38 PM.


Copyright