Turn Signal fuse blowing - Defender Source
Defender Source  

Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions


Reply
 
Thread Tools
  #1  
Old June 6th, 2014, 11:33 AM
toad's Avatar
toad
Status: Offline
Cutter
None
Member
 
Join Date: Feb 2012
Location: Rhode Island
Posts: 253
Turn Signal fuse blowing

I am trying to track down an electrical gremlin in my new to me 86 110. The fuse that the turn signal is on is blowing. I replaced the turn signal switch with a new unit but it is still blowing. When I put a new fuse in it works for a bit, the trailer dash light turns on intermittently when I use the left indicator. When the fuse blows and I engage the hazards the trailer dash light blinks instead of the indicator light.

I've seen in searches that the hazard switches on these goes, I'm thinking this is the next thing to check but I'd like to see what else is on the circuit that could be doing this since the signals seem to work just fine when before the fuse blows.
Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old June 6th, 2014, 11:36 AM
Uncle Douglas's Avatar
Uncle Douglas
Status: Offline
Doug Crowther
A defender in every driveway-motto
D-90 Source Vendor
 
Join Date: Dec 2007
Location: Gods Country- Central Virginia
Posts: 11,835
Registry
I'd guess a short. Ie bare wire touching ground somewhere.
__________________
Good judgement comes from experience,experience comes from bad judgement.

Dividing Creek Imports
Worldwide Vehicle Shipment and Importation Service
Restoration & Modification work


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

410.693.1391


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Reply With Quote
  #3  
Old July 20th, 2014, 04:44 PM
samer0214's Avatar
samer0214
Status: Offline
Samer Hijazi
1997 P38 Vitesse
Member
 
Join Date: Apr 2013
Location: Irvine, CA
Posts: 390
Registry
I'm having the same type of problem. I replaced all of the driving lights and turn signal assemblies front and back along with a new turn signal/horn stalk, and when I engage the turn signal in either direction, I can hear the relay clicking and then the fuse blows. Neither bulbs will flash though.

Shorting problem as well? I'm thinking reversed leads, which would translate to the same?
__________________
Thank you - Samer
1997 P38 Vitesse (Red)
2003 Discovery II
Defenderless, for now!
Reply With Quote
Sponsored Links
Advertisement
 
  #4  
Old July 21st, 2014, 10:12 AM
samer0214's Avatar
samer0214
Status: Offline
Samer Hijazi
1997 P38 Vitesse
Member
 
Join Date: Apr 2013
Location: Irvine, CA
Posts: 390
Registry
Bump
__________________
Thank you - Samer
1997 P38 Vitesse (Red)
2003 Discovery II
Defenderless, for now!
Reply With Quote
  #5  
Old July 22nd, 2014, 10:48 AM
Nashville's Avatar
Nashville
Status: Offline
Victor Hess
1997 Defender 90 NAS
Member
 
Join Date: Feb 2014
Location: Nashville, TN, USA
Posts: 72
Registry
I'm sure it was a complete coincidence, but only my trailer light would come on when I used the turn signals. This went away when I replaced all the warning light bulbs in the dash and the indicator blinker worked again. I haven't seen the trailer light since.
__________________
1997 D90 ST NAS #1426
British Racing Green
Reply With Quote
  #6  
Old July 22nd, 2014, 10:52 AM
KKilo23's Avatar
KKilo23
Status: Offline
Kenny
NAS SW l NAS ST l 110 SW | 110 Crew
Member
 
Join Date: Apr 2005
Location: Saratoga Springs, NY
Posts: 2,065
Registry
Short. I had the same issue before I replaced my harness. A wire frayed and was touching the metal on the frame. Just need to track it down.
Reply With Quote
  #7  
Old July 22nd, 2014, 11:03 AM
samer0214's Avatar
samer0214
Status: Offline
Samer Hijazi
1997 P38 Vitesse
Member
 
Join Date: Apr 2013
Location: Irvine, CA
Posts: 390
Registry
Turn Signal fuse blowing

I went back and rechecked all 4 turn signal assemblies yesterday and found out that I had reversed the connections on the 2 front ones. The color coding of the wires was reversed during manufacturing. I also made shure that all bulbs were fine by feeding them a 12 volt signal.

The good news is that the fuse in no longer blowing, but I still have a problem:

1) the immergency flashers will not work when I activate the flasher button in the dash, unless the turn signal stalk is also activated in either direction (it doesn't matter if it's left or right)
2) the turn signal itself doesn't work all the time, it's intermittent, and only seems to work properly after I "reset" the circuit by turning the flashers on and off
3) the left rear corner turn signal is not working at all, whether I activate the flashers or the turn signal stalk

BTW, the turn signal stalk is completely new.
__________________
Thank you - Samer
1997 P38 Vitesse (Red)
2003 Discovery II
Defenderless, for now!
Reply With Quote
  #8  
Old July 22nd, 2014, 11:18 AM
javelinadave
Status: Offline
-
-
Member
 
Join Date: Sep 2003
Location: -
Posts: 5,394
Sam,
Did you try changing the hazard switch? That or the flasher cure 90% turn signal issues. As for Toads issue(s) it sounds like an intermittent short somewhere in his system.
Reply With Quote
Reply

Lower Navigation
Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions

Tags
signal, wing

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Fuse Box: Glass fuse --> Spade Fuse gonzanc Defender Technical Discussions 20 October 27th, 2016 11:54 PM
60amp accessory fuse B blowing in main fuse box owen Defender Technical Discussions 5 March 31st, 2013 09:18 AM
Quick ?, do front turn signal wires go directly to the relay behind fuse cover Neil McCauley Defender Technical Discussions 3 January 6th, 2012 08:23 PM
Repeatedly blowing undehood 30A fuse Hans Defender Technical Discussions 1 September 6th, 2005 04:24 PM
Blowing wiper/speedo fuse like crazy....help! P1CR Defender Technical Discussions 4 March 11th, 2004 03:23 PM


All times are GMT -5. The time now is 12:19 PM.


Copyright