Temperature indication - Defender Source
Defender Source  

Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions

Join the Defender Source Community Today

Thread Tools
Old December 27th, 2012, 10:58 AM
atpick's Avatar
Status: Offline
1990 110
Join Date: Nov 2010
Location: Cambridge, UK
Posts: 276
Temperature indication

I am trouble shooting a temp indication issue in my 110 and am looking for a little help. Trying to find the cause. When I turn the key, the temp gauge needle does move every so slightly, but will never move farther than that (remains just below "C"). The engine is obviously warming as at the end of the day I can feel a normal amount of heat from the engine when I check. I was curious as to you guys thoughts. Do you think it is the gauge, the temp sender, or the wiring? I changed out the contact on the temp sender which was a little corroded and still get the same result. Looking for ideas before I buy parts.


Reply With Quote
Old December 27th, 2012, 11:04 AM
Rocky's Avatar
Status: Offline
72 + D1 drivetrain
Join Date: Sep 2006
Location: Colonies
Posts: 7,531
Replace the sender.
Reply With Quote

Lower Navigation
Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Temperature Gague false reading trick? arbik Defender Technical Discussions 65 September 26th, 2010 07:48 PM
300 TDi coolant temperature range cdb Defender Technical Discussions 13 February 20th, 2008 05:44 PM
Temperature sender thread type/pitch? Neo Defender Technical Discussions 4 March 9th, 2006 02:40 PM
Transmission temperature gauge ripp2002 Defender Technical Discussions 27 February 12th, 2005 08:42 AM
Temperature Gauge doesn't work...?? norros Defender Technical Discussions 4 May 19th, 2004 03:11 PM

All times are GMT -5. The time now is 11:02 AM.