TD5 Speedo starts 20 below 0 ?! - Defender Source
Defender Source  

Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions


Reply
 
Thread Tools
  #1  
Old December 24th, 2015, 12:09 PM
WestCoastRover's Avatar
WestCoastRover
Status: Offline
Jeff
2000 TD5
Member
 
Join Date: Dec 2014
Location: Vancouver, BC, Canada
Posts: 132
Registry
Unhappy TD5 Speedo starts 20 below 0 ?!

Need some help. My speedometer in my 1999 Defender 90 TD5 starts 20km/hr below 0 (physically). Right against the odo reset. Example, You're doing 60km/h and the gauge reads 40km/h. You're parked, it's -20km/h.

Is there a solution?

Thanks!
Reply With Quote
Sponsored Links
Advertisement
 
Reply

Lower Navigation
Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions

Tags
speedo, start, td5

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
BAD squeeking from below rover4x4 Defender Technical Discussions 20 February 16th, 2007 08:11 PM
Speedometer cable... standard threads down below? Hans Defender Technical Discussions 0 January 13th, 2007 09:33 PM
surprised at 300Tdi cold weather starts Gkase Misc. Chit-Chat 6 December 6th, 2006 09:11 AM
Strange Noises from below easy Defender Technical Discussions 37 June 21st, 2005 09:31 AM
D90 Starts Slowly. Any ideas? cdnpaul Defender Technical Discussions 7 October 31st, 2003 11:27 PM


All times are GMT -5. The time now is 06:06 PM.


Copyright