Tach works off and on - Defender Source
Defender Source  

Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions

Join the Defender Source Community Today

Thread Tools
Old November 18th, 2004, 10:41 AM
mdmccallum's Avatar
Status: Offline
'97 Defender 90 SW
Join Date: Dec 2003
Location: Durango, Colo.
Posts: 425
Tach works off and on

I noticed a burnt rubber smell yesterday while driving home. Then noticed that the tachometer was not working. Everything else seemed to be fine. I first thought is that the fan belt is loose since I had a pulley wear out about 2months ago. Oh, I also have had some intermittent fan belt screaming. So, when I get home today I plan to investigate but in the meantime does anyone have any ideas as to what else it may be?

Reply With Quote
Old November 18th, 2004, 11:32 AM
Mike Hippert's Avatar
Mike Hippert
Status: Offline
94 D-90 Grinding Rover
Join Date: Sep 2003
Location: Manchester NH USA
Posts: 4,790
check the wires on the back of the alt, the tach wire may have come loose, you may want to pick up some spare belts also.

Don't forget to Search first then ask questions later! The loose nut behind the wheel
Reply With Quote
Old November 18th, 2004, 07:25 PM
4WD-90's Avatar
Status: Offline
Christopher Stanish
1994 defender 90
Join Date: Oct 2004
Location: Huntingdon Valley,PA.USA
Posts: 47
I had a similar issue with my temp gauge. It turned out to be the plastic covering on the crimp-on wire connector(Sta-Kon) had loosened away from the crimp end, shorting out to the mounting bracket and causing the gauge to read incorrectly. It sounds like maybe your connection has gotten loose, caused arching/heat etc, and might have melted the insulation on the wire?
Reply With Quote

Lower Navigation
Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

All times are GMT -5. The time now is 07:27 AM.