Strange... - Defender Source
Defender Source  

Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions


Reply
 
Thread Tools
  #1  
Old June 22nd, 2005, 09:33 AM
Campbell's Avatar
Campbell
Status: Offline
Rich Campbell
06 LR3 01DII D90s sold
Member
 
Join Date: Oct 2003
Location: PA
Posts: 1,512
Registry
Strange...

Here is a new one. I have been hearing a squeak noise when turning or slight bend to the left. Sounded like the brake pads but it didn't go away when pressing the brake hard while turning. Anyway, I was coiming in today and heard a pop noise followed by the noise dissapearing. Sounded like I ran over a beer can or something.........noise is gone.
Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old June 22nd, 2005, 04:17 PM
Mike Hippert's Avatar
Mike Hippert
Status: Offline
D-90Slut/Stalker,SNLPres
94 D-90 Grinding Rover
Member
 
Join Date: Sep 2003
Location: Manchester NH USA
Posts: 4,789
Could have been the mud shield was bent in and rubbing the break rotor and it may have just popped back into place.
__________________
Don't forget to
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
first then ask questions later! The loose nut behind the wheel
Reply With Quote
  #3  
Old June 22nd, 2005, 10:48 PM
evilfij's Avatar
evilfij
Status: Offline
evilfij
I have never seen a rover in person
Member
 
Join Date: Oct 2003
Location: on the internet
Posts: 14,688
Sounds like maybe a bad ball joint.
__________________
*not legal advice*
Reply With Quote
Sponsored Links
Advertisement
 
  #4  
Old June 22nd, 2005, 11:59 PM
Davis's Avatar
Davis
Status: Offline
Chris Davis
94 NAS D90 6.2LS
Member
 
Join Date: Nov 2003
Location: Colorado
Posts: 2,507
he he he....you said ball......he he he...
Reply With Quote
  #5  
Old June 23rd, 2005, 12:42 AM
evilfij's Avatar
evilfij
Status: Offline
evilfij
I have never seen a rover in person
Member
 
Join Date: Oct 2003
Location: on the internet
Posts: 14,688
he he

Maybe his cam is installed too far in
__________________
*not legal advice*
Reply With Quote
  #6  
Old June 23rd, 2005, 08:06 AM
Campbell's Avatar
Campbell
Status: Offline
Rich Campbell
06 LR3 01DII D90s sold
Member
 
Join Date: Oct 2003
Location: PA
Posts: 1,512
Registry
If it is a ball joint what should I look for to see if it is bad. Any noise?
Everything seems fine now.

Ron, I saw your post on needing a picture of a 95 a/c system. I have the 95 system in my 94. Let me know if you need to see it in person.
Rich
Reply With Quote
  #7  
Old June 23rd, 2005, 09:40 PM
evilfij's Avatar
evilfij
Status: Offline
evilfij
I have never seen a rover in person
Member
 
Join Date: Oct 2003
Location: on the internet
Posts: 14,688
Hi Rich,

Thanks for the offer. I have a pic but I may take you up on that if I cannot figure it out this weekend.

Check the ball joints and see if they are tight or if the track rod/tie rod move and the ball joints make a noise when you grab them.

Next few things to check would be wheel bearings and maybe a CV joint and maybe a once over on all the bushings.

Ron
__________________
*not legal advice*
Reply With Quote
  #8  
Old June 24th, 2005, 07:41 AM
Campbell's Avatar
Campbell
Status: Offline
Rich Campbell
06 LR3 01DII D90s sold
Member
 
Join Date: Oct 2003
Location: PA
Posts: 1,512
Registry
Thanks Ron,
It happened again today. Also, my parking brake isn't working as well. I have to pull it all the way up just to do something and the light no longer comes on. Must be related somehow.
Reply With Quote
  #9  
Old June 24th, 2005, 08:57 AM
flippedrover's Avatar
flippedrover
Status: Offline
Tyler
'94 D-90
Member
 
Join Date: Dec 2003
Location: Ashburn,va
Posts: 3,125
The light is just the switch in the lever. Mine works if I wack it hard.
__________________
Can't you feel 'em circlin' (closin'in) honey?
Can't you feel 'em swimmin' around?
You got fins to the left, fins to the right,
and you're the only bait in town.
You got fins to the left, fins to the right,
and you're the only girl in town.

Jimmy Buffett


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Reply With Quote
  #10  
Old June 24th, 2005, 10:49 PM
evilfij's Avatar
evilfij
Status: Offline
evilfij
I have never seen a rover in person
Member
 
Join Date: Oct 2003
Location: on the internet
Posts: 14,688
That could be. Make sure everything is tight down there.
__________________
*not legal advice*
Reply With Quote
Reply

Lower Navigation
Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Strange things growing in my wife's garden... Trigger Misc. Chit-Chat 9 August 30th, 2005 02:26 AM
strange heat issue jabber Defender Technical Discussions 15 March 6th, 2005 05:42 PM
Strange feeling while driving... wicks Misc. Chit-Chat 5 March 3rd, 2005 01:37 PM
strange 9/11 video jperakis Misc. Chit-Chat 2 January 17th, 2005 07:35 PM
Strange sounds ronward Misc. Chit-Chat 6 March 23rd, 2004 04:36 AM


All times are GMT -5. The time now is 08:15 AM.


Copyright