Stock Radio Problem - Defender Source
Defender Source  

Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions


Reply
 
Thread Tools
  #1  
Old March 22nd, 2012, 11:12 AM
1of40's Avatar
1of40
Status: Offline
1of40
NAS 97SW & 83 One Ten Tdi
Member
 
Join Date: Dec 2003
Location: Potomac Falls & Wintergreen, Virginia
Posts: 6,075
Registry
Stock Radio Problem

Experiencing some unusual problems with my stock radio. Just this week when in Radio mode is sounds like i'm getting a spotty signal. If I change stations things sometimes go back to normal for a little while. If I change modes, from radio to CD and back to radio, it fixes the problem for a little while. I've checked/played with the antenna connection and it's all normal. Just wondering if anyone else has experienced the same problem.

thanks,
Clay
Reply With Quote
Sponsored Links
Advertisement
 
Reply

Lower Navigation
Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions

Tags
radio

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
iPod connection to stock radio ditskovich Defender Technical Discussions 5 April 18th, 2011 10:39 AM
Insert for radio on stock center console bitz Wanted 1 October 14th, 2009 05:08 PM
on-going electrical problem... vesparover Defender Technical Discussions 3 October 23rd, 2003 11:13 AM
Stock 90 Parts for Sale Joe B For Sale - Parts 2 October 15th, 2003 11:57 AM
97 radio plug arrangements Gkase Defender Technical Discussions 1 October 6th, 2003 06:58 PM


All times are GMT -5. The time now is 10:39 AM.


Copyright