STILL wont start - Defender Source
Defender Source  

Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions

Join the Defender Source Community Today

Thread Tools
Old June 29th, 2009, 07:42 AM
Status: Offline
david summers
99 Discovery II
Join Date: Aug 2007
Location: fort worth, tx usa
Posts: 108
Angry STILL wont start

94 still will not start (10 + days now). To recap:
It does have spark at the plugs
The fuel pump runs for 2-3 seconds when the key is turned on and fuel comes out of the high pressure line.
I have checked every fuse that I can find, all have been fine
I have voltage at the fuel injector plugs
The fuel injector plugs are NOT firing. Test light shows no pulses when the engine is cranked. Both banks show NO pulses when the engine is cranked.
I have even swapped ECUs; still the fuel injectors are not getting the signal to squirt. I have swapped the 30 amp silver relay next to the fuel pump relay.
I have checked the voltage to the MAF, I have tried disconnecting the MAF. Still no start. Engine just cranks, no sputtering, no gas smell.
ANY ideas on what would be stopping the ECU from "telling" the fuel injectors to inject fuel?
Reply With Quote

Lower Navigation
Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Truck will not START ? Weldon Defender Technical Discussions 28 December 15th, 2005 12:58 PM
HELP 94 d90 will not start ripp2002 Defender Technical Discussions 64 August 25th, 2005 07:43 AM
95 won't start, possible fuel priming issue? jcasteel Defender Technical Discussions 1 March 15th, 2005 09:45 AM
Rats! Now my D90 won't start. No power to fuel pump jcasteel Defender Technical Discussions 8 March 15th, 2005 09:42 AM
Ignition Relocation = No Start...Help JRowe Defender Technical Discussions 5 March 8th, 2004 12:45 PM

All times are GMT -5. The time now is 08:57 PM.