stereo doesn't work, but everything else does. - Defender Source
Defender Source  

Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions


Reply
 
Thread Tools
  #1  
Old April 27th, 2012, 01:02 PM
rd10014's Avatar
rd10014
Status: Offline
Ronnie
1993 NAS D110
Member
 
Join Date: Mar 2012
Location: NYC
Posts: 923
Registry
stereo doesn't work, but everything else does.

The radio was fine for up until a week ago, I started the truck and it didn't work. Two days later it did, now it hasn't worked the past three times using the truck. Any suggestions, is there a fuse or something I can focus on here? I have a 1997 NAS D90.

Thanks.
Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old April 27th, 2012, 01:49 PM
leastonce's Avatar
leastonce
Status: Offline
Jason England
D-90 White 95 SW #65
Site Team
 
Join Date: Jul 2009
Location: NYC
Posts: 6,078
Registry
Is it original?

Generally stereo's have 3 live feeds .... one that is constant to provide memory backup, one that switches with the accesory on the ignition switch and one that connects to the lighting circuit to provide illumination when you switch the headlights on.

So when it doesn't work ...

Does it illuminate with the headlights? if not - likely earth on the radio

When it does work - are the memory pre-sets stored? - likely main power connector. Older aftermarket radios had inline fuse holder which may cause problem.
__________________
Quote:
Soapy water / KY jelly, etc. is is basically a must. Yes, good idea to remove trim panels - only takes 5 more minutes to do so.
Car Camping Collective founding member and Chief Executive Officer
Cat Camping Collective founding member and Chief Executive Officer
Reply With Quote
  #3  
Old April 27th, 2012, 01:59 PM
rd10014's Avatar
rd10014
Status: Offline
Ronnie
1993 NAS D110
Member
 
Join Date: Mar 2012
Location: NYC
Posts: 923
Registry
Quote:
Originally Posted by leastonce View Post
Is it original?

Generally stereo's have 3 live feeds .... one that is constant to provide memory backup, one that switches with the accesory on the ignition switch and one that connects to the lighting circuit to provide illumination when you switch the headlights on.

So when it doesn't work ...

Does it illuminate with the headlights? if not - likely earth on the radio

When it does work - are the memory pre-sets stored? - likely main power connector. Older aftermarket radios had inline fuse holder which may cause problem.
No it's not, I'm getting a new one in a couple days.

Feeds:
Got it, don't remember if last time it worked if the stations where pre set still. The stereo was always illuminated.

Currently there's NO power at all, earth on the radio?? do you mean the ground? If so where do i find this, I'm assuming near the battery correct? Funny thing is it just worked 4 days ago.

Thank you
Reply With Quote
Sponsored Links
Advertisement
 
  #4  
Old April 27th, 2012, 02:06 PM
leastonce's Avatar
leastonce
Status: Offline
Jason England
D-90 White 95 SW #65
Site Team
 
Join Date: Jul 2009
Location: NYC
Posts: 6,078
Registry
I'd just get the new one and see if that fixes it.

Are you planning to install yourself ( I could assist if you need) or have it done by a shop?

yes sorry earth in the UK - ground in the US ... spending too much time in canada at the moment and they use a lot of british words ...
__________________
Quote:
Soapy water / KY jelly, etc. is is basically a must. Yes, good idea to remove trim panels - only takes 5 more minutes to do so.
Car Camping Collective founding member and Chief Executive Officer
Cat Camping Collective founding member and Chief Executive Officer
Reply With Quote
Reply

Lower Navigation
Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions

Tags
stereo

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
stock stereo trouble 95st Brent Nevin Defender Technical Discussions 5 April 8th, 2010 07:49 AM
Various D90 Parts - OE Stereo/ CD Changer/ Brush Guard TurkD90 For Sale - Parts 1 July 30th, 2005 03:15 PM
Stereo Wiring Harness Manufacturer? priest944 Defender Technical Discussions 7 January 11th, 2005 06:03 PM
not safe for work lobster Misc. Chit-Chat 10 November 5th, 2004 06:51 PM
Custom Work mgrgpg Misc. Chit-Chat 6 November 14th, 2003 08:59 AM

» Defender Registry

Blu

Cred

TOAD

SaltyDog
Add your Defender

All times are GMT -5. The time now is 04:36 AM.


Copyright