Starting problems now - Defender Source
Defender Source  

Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions

Join the Defender Source Community Today

Thread Tools
Old January 6th, 2008, 03:01 PM
Status: Offline
Matt J.
None at the moment
Join Date: Dec 2006
Location: Maryland
Posts: 402
Starting problems now

Sorry fellas but, as usual, I need some help.

I just replaced the viscous coupling - it's a simple thing to all of you fellers, but to me it was a big victory... the battery was weak anyway before I parked it for that, so I disconnected the battery while I fought the VC battle. I got the VC replacement finished, reconnected the battery, tried a jumper pack AND jump-starting... and nothing. No motion at all. Lights all come on, it pumps up the steering pump... but turn the key and absolutely nothing happens.

It's never failed to turn over, even with the battery near death. It's been parked for about 3 weeks disconnected.

I do have an electrical leak somewhere I haven't diagnosed - lost my digital multimeter. Possibly related?

I'm afraid it's the starter motor, but there's a reverse light / start inhibit bit that might be problematic... except the reverse lights come on fine.

??? I would be most appreciative of any useful advice. I have been working on this Rover since spring as many of you recall, and planned to FINALLY take it to the inspection station this week for a final alignment and (hopefully, successful) inspection.

Ya know, it's funny... every single time I fix one thing, another, unrelated issue creeps up and I'm back under the truck or into the engine. I think that I'm going insane ha-ha-hee-hee...
Reply With Quote

Lower Navigation
Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions

problems, start, starting

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Starting problems - battery or alternator tboyle27 Defender Technical Discussions 1 June 19th, 2006 03:35 PM
Starter Problems...Yikes boshea Defender Technical Discussions 5 September 9th, 2005 06:56 PM
Server Connection Problems chrisvonc Community News & Announcements 1 July 25th, 2004 09:22 PM
Problems with registering chrisvonc Support & Suggestions 0 November 7th, 2003 10:36 AM
Ignition problems boshea Defender Technical Discussions 7 October 7th, 2003 07:48 AM

All times are GMT -5. The time now is 07:33 PM.