starting problems and correct voltage to fuel pump - Defender Source
Defender Source  

Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions


Reply
 
Thread Tools
  #1  
Old July 26th, 2009, 03:07 PM
cdb
Status: Offline
Clark Bowen
1969 Series 2a/OM617 Bugeye 88"
Member
 
Join Date: Jun 2006
Location: Oregon, USA
Posts: 775
starting problems and correct voltage to fuel pump

It has been taking a seemingly long time for 1991 RRC to start and yesterday it got worse to the point that it took me an hour of trying before it would fire and run.
I looked at the threads on this subject (pre-4.0 litre) and the closest problem to mine never showed a resolution:

The relay clicks when I turn the key off and on
The fuel pump works when I supplied 12v

The voltage to the fuel pump was only 5.35v - is that correct.

The pump would pump sometimes when I turned the switch to "on" (I tested with an undone fuel line and listening for the motor) and sometimes not

I'm not sure how to test the fuel temp sensor - ohms?

The ignition switch acted strange. Sometimes after cranking for a long time, when I turned it off and then on, no lights showed and when I then tried to crank it nothing happened. This appears to be a ignition switch issue - yes?

I did notice many cracked rubber boots on various engine electrical connections (injectors, fuel thermistor) and wonder what to do about them. Electrical tape always unravels and I can't fir shrink tape over the connector.

Follow-up Post:

One more thing:

Recently the engine began to rev way up 1,500+ RPM at start - cold or hot - and then slowly stepped down to a normal idle.
__________________
2011 RR HSE -
1970 LR Series 2A Bugeye BenzOver
2001 GMC 2500 4wd
Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old July 28th, 2009, 11:31 AM
cdb
Status: Offline
Clark Bowen
1969 Series 2a/OM617 Bugeye 88"
Member
 
Join Date: Jun 2006
Location: Oregon, USA
Posts: 775
Turned out to be the ignition switch....seems to be a common problem
__________________
2011 RR HSE -
1970 LR Series 2A Bugeye BenzOver
2001 GMC 2500 4wd
Reply With Quote
Reply

Lower Navigation
Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions

Tags
fuel, problems, start, starting

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Re: Mallory Distributor Mpigapicha Defender Technical Discussions 8 January 13th, 2010 11:24 PM
300 Tdi weissbrewer For Sale - Parts 37 October 5th, 2008 06:40 PM
NAS 110 Stalls Climbing Hills R. Kurk Defender Technical Discussions 32 October 30th, 2007 03:40 PM
97 SW rear door electical problems! Hammertime Defender Technical Discussions 1 September 4th, 2007 08:51 PM
Rebuilding a v8 engine - how to fix liner problems robisonservice Defender Technical Discussions 10 August 19th, 2006 10:18 PM


All times are GMT -5. The time now is 10:37 AM.


Copyright