Starting issue - Defender Source
Defender Source  

Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions


Reply
 
Thread Tools
  #1  
Old August 18th, 2013, 11:58 AM
usadventureracing's Avatar
usadventureracing
Status: Offline
Brett
110
Member
 
Join Date: Jul 2010
Location: US
Posts: 569
Starting issue

Once I get it started she runs great, but the issue is - sometimes not all times when I turn the key there is a delay or the starter does not spin. I am thinking it is a short or the ignition switch. Has anyone experienced this? Does anyone have a part number for the ignition switch for an 83 110 v8 rhd.

Thanks
__________________
1983 ROW D110
1970 Series III (Parting out)
Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old August 19th, 2013, 12:28 PM
flippedrover's Avatar
flippedrover
Status: Offline
Tyler
'94 D-90
Member
 
Join Date: Dec 2003
Location: Ashburn,va
Posts: 3,124
Check your battery and the cable running to the trigger on the starter.
__________________
Can't you feel 'em circlin' (closin'in) honey?
Can't you feel 'em swimmin' around?
You got fins to the left, fins to the right,
and you're the only bait in town.
You got fins to the left, fins to the right,
and you're the only girl in town.

Jimmy Buffett


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Reply With Quote
  #3  
Old August 19th, 2013, 03:35 PM
genie90's Avatar
genie90
Status: Offline
Jay Geaney
1994 D-90 ST #282
Member
 
Join Date: Oct 2010
Location: Little Rock, AR, USA
Posts: 814
Part is 551508.

I think you are correct in assuming it's the ignition switch.

Cheers
Jay
Reply With Quote
Reply

Lower Navigation
Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Not starting '95 what to check next. jcasteel Defender Technical Discussions 17 June 10th, 2005 02:38 PM
Help with engine not starting cbass Defender Technical Discussions 4 April 5th, 2005 12:12 PM
95 won't start, possible fuel priming issue? jcasteel Defender Technical Discussions 1 March 15th, 2005 09:45 AM
Fun new problem: starter circuit issue jaherring Defender Technical Discussions 1 September 12th, 2004 03:07 AM
Hard starting, everything else fine? Doug Defender Technical Discussions 16 July 11th, 2004 01:25 PM


All times are GMT -5. The time now is 08:17 PM.


Copyright