Stalling RR? - Defender Source
Defender Source  

Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions


Reply
 
Thread Tools
  #1  
Old March 17th, 2005, 01:24 AM
headdamage's Avatar
headdamage
Status: Offline
Andrew
exmod 90 2.5na and a 93/RRC 200tdi
Member
 
Join Date: Dec 2004
Location: Yellowknife NWT
Posts: 227
Stalling RR?

Hi,

My NAS 1987 Range Rover has sort of died. For the past few weeks it has tended to stall on the first start of the day and be a little difficult to restart then it is ok for the rest of the day. As of a couple of days ago it go worse. When I first get into it and try to start it it fires right but but then seems to run out of gas within about 4 or 5 seconds. Trying to restart just results in alot of cranking and no action. If I try again a few hours later it starts agian and then dies agian. The fuel pump and relay sound like they are working and my feeling is that it is a lack of fuel not a lack of spark. I suspect a clogged fuel filter and will try that first but am asking here incase anyone has had this happen. My fuel gauge also started acting up a month or so ago and I haven't fixed that yet, related issue? Thanks for any input.

Andrew
BTW... I have a 1987 RR engine and tranny in my project 90 so it is sort of a 90 question to incase I run into the same problem there
Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old March 17th, 2005, 01:56 AM
thelandroverguy's Avatar
thelandroverguy
Status: Offline
Vince
1997 D-90 ST
Member
 
Join Date: Jun 2004
Location: Los Angeles
Posts: 49
My 90 Classic (1990) Was stalling and running rough on start up. Also when coming to a fast stop. I removed and cleaned the idle stepper moter and the problem eased up. I replaced it with a cross over part at Pep Boys for 30 bucks and the rig has been fine since.

Try this link for more info about the stepper motor http://www.rangerovers.net/rrpartsv.htm#stepper Hope this helps.
Reply With Quote
  #3  
Old March 18th, 2005, 02:33 AM
little black duck's Avatar
little black duck
Status: Offline
Michael Jude
2004/D90 Td5
Member
 
Join Date: Feb 2005
Location: Newcastle, Australia
Posts: 11
I had a 91 Disco that had a few tempermental issues.

The starting problem on my disco was because of a blown head gasket, I also had a problem with it turning off whilst drivig down the road. the naswer to the second on was to remove the after market immobiliser.

Is it using any fluids excessivelly?

Michael
Reply With Quote
Sponsored Links
Advertisement
 
  #4  
Old March 19th, 2005, 08:06 PM
headdamage's Avatar
headdamage
Status: Offline
Andrew
exmod 90 2.5na and a 93/RRC 200tdi
Member
 
Join Date: Dec 2004
Location: Yellowknife NWT
Posts: 227
No fluid problems.

Changed fuel filer
Checked fuel pressure (38psi)
Charged batt
Tried another good coil
Tried another good ECU

I don't know what is wrong but it still starts good then shuts off in a few seconds and will not restart untill you let it sit for a couple of hours then it does the same thing again.
Reply With Quote
  #5  
Old March 19th, 2005, 10:25 PM
Hans's Avatar
Hans
Status: Offline
Hans Haase
The D-90.com Lab Rat
Member
 
Join Date: Oct 2003
Location: Long Island, NY
Posts: 2,381
Could be a bad ignition module on the distributor, they have a known problem with going bad over time due to the heat underhood.

-Hans
__________________
My oil line fix

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
My 100k stopped odometer fix

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Brace for impact, I'm in a "modifying mood". Massive thread count inbound.
Reply With Quote
  #6  
Old March 20th, 2005, 12:29 AM
headdamage's Avatar
headdamage
Status: Offline
Andrew
exmod 90 2.5na and a 93/RRC 200tdi
Member
 
Join Date: Dec 2004
Location: Yellowknife NWT
Posts: 227
Well I messed around with it some more and followed the whole electronics check routine in the manual and now it is running fine. It was the Throttle pot, it was out of adjustment.
Reply With Quote
Reply

Lower Navigation
Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Stalling problem HELP esprit99 Defender Technical Discussions 6 February 8th, 2007 08:21 AM
stalling bjenk Defender Technical Discussions 5 May 7th, 2005 12:56 AM
stalling and sputtering roverboy Defender Technical Discussions 7 November 4th, 2004 04:19 PM
Stalling problem and fault codes James Defender Technical Discussions 5 July 22nd, 2004 07:29 PM
Why is my D90 stalling? JRowe Defender Technical Discussions 4 November 10th, 2003 04:17 PM


All times are GMT -5. The time now is 04:30 AM.


Copyright