Stalling problem HELP - Defender Source
Defender Source  

Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions


Reply
 
Thread Tools
  #1  
Old February 7th, 2007, 08:52 AM
esprit99's Avatar
esprit99
Status: Offline
Keith Imbriglio
1997 D90 SW Arles Blue
Member
 
Join Date: Sep 2005
Location: Western, MA, USA
Posts: 63
Stalling problem HELP

I'm wondering if anyone has any input on a stalling problem with a 1997 D90 4.0 engine, all stock accept a snorkel. The truck starts and runs fine untill full warm up; After full warm up, if the truck is in park/nutural it will stall. Having the truck in drive will keep the idle up just enough to prevent stalling. While the engine is warming up the idle is 900 RPM, normal and fine, when warm and in gear 600/650 RPM and on the edge of stalling, when warm and in park the truck stalls. It seems to me to be a sensor problem. No check engine lights. Any thoughts?
__________________
Life is to short to drive ugly cars
'97 D90 SW #2251 Arles blue
'16 RRE
'04 Disco
Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old February 7th, 2007, 09:29 AM
Chaucer
Status: Offline
Will
93 110 | 97 90
Member
 
Join Date: Oct 2003
Location: WA
Posts: 583
I had that problem...Ran a can of BG 44k through half a tank of gas - cleaned everything up.
Reply With Quote
  #3  
Old February 7th, 2007, 09:37 AM
esprit99's Avatar
esprit99
Status: Offline
Keith Imbriglio
1997 D90 SW Arles Blue
Member
 
Join Date: Sep 2005
Location: Western, MA, USA
Posts: 63
Sorry for the ignorance but what is that.
__________________
Life is to short to drive ugly cars
'97 D90 SW #2251 Arles blue
'16 RRE
'04 Disco
Reply With Quote
Sponsored Links
Advertisement
 
  #4  
Old February 7th, 2007, 10:28 AM
Chaucer
Status: Offline
Will
93 110 | 97 90
Member
 
Join Date: Oct 2003
Location: WA
Posts: 583
It's a fuel system cleaner...cleans your injectors. I think the problem you might have is carbon build-up. It's expensive stuff, like $19-20 per 11 or 11.5oz container. For me and my problem (almost exactly what you are describing above) it cleared it up real nicely. Not a silver bullet, but worth a shot.
Reply With Quote
  #5  
Old February 7th, 2007, 10:55 AM
esprit99's Avatar
esprit99
Status: Offline
Keith Imbriglio
1997 D90 SW Arles Blue
Member
 
Join Date: Sep 2005
Location: Western, MA, USA
Posts: 63
Thanks for your input, I'll try it. Anyone have any other ideas.
__________________
Life is to short to drive ugly cars
'97 D90 SW #2251 Arles blue
'16 RRE
'04 Disco
Reply With Quote
  #6  
Old February 7th, 2007, 12:07 PM
BarryO
Status: Offline
Barry O'Mahony
97 D-90 SW LE
Member
 
Join Date: Dec 2003
Location: Bend, OR
Posts: 281
Could be the infamous stepper motor (idle air valve)?
Reply With Quote
  #7  
Old February 8th, 2007, 08:21 AM
esprit99's Avatar
esprit99
Status: Offline
Keith Imbriglio
1997 D90 SW Arles Blue
Member
 
Join Date: Sep 2005
Location: Western, MA, USA
Posts: 63
Probleme fixed

FYI removed and cleaned the stepper motor. Reinstalled the stepper and disconnected and reconnected the battery. Also running fuel injector cleaner in fuel. So far so good. Thanks for the ideas.
__________________
Life is to short to drive ugly cars
'97 D90 SW #2251 Arles blue
'16 RRE
'04 Disco
Reply With Quote
Reply

Lower Navigation
Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Wobbly distributor cap? and an update on my starter problem MiniGuy Defender Technical Discussions 6 January 10th, 2006 10:13 AM
stalling bjenk Defender Technical Discussions 5 May 7th, 2005 12:56 AM
Fun new problem: starter circuit issue jaherring Defender Technical Discussions 1 September 12th, 2004 03:07 AM
Stalling problem and fault codes James Defender Technical Discussions 5 July 22nd, 2004 07:29 PM
on-going electrical problem... vesparover Defender Technical Discussions 3 October 23rd, 2003 11:13 AM


All times are GMT -5. The time now is 11:37 AM.


Copyright