speedometer not working - Defender Source
Defender Source  

Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions


Reply
 
Thread Tools
  #1  
Old January 25th, 2011, 09:06 AM
TexasD-90's Avatar
TexasD-90
Status: Offline
Martin Spencer
1994 D-90
Member
 
Join Date: Sep 2005
Location: Graford, TX, USA
Posts: 268
speedometer not working

Some of you may have read and responded to my post about shredding my rear diff (thanks for the help). The same time that happened, I lost my speedometer and my odometer. Any suggestions? The cable was replaced in May, and is attached firmly to the speedometer gage itself. What should I check next?
__________________
That is why it is called a short cut. If it was easy it would just be "the way."
Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old January 25th, 2011, 09:08 AM
leastonce's Avatar
leastonce
Status: Offline
Jason England
D-90 White 95 SW #65
Site Team
 
Join Date: Jul 2009
Location: NYC
Posts: 6,078
Registry
take the speedo head off ... drive down the road and see if it's turning ... that way you can check the the lower components are working.
Reply With Quote
  #3  
Old January 27th, 2011, 02:01 PM
Defender90_218's Avatar
Defender90_218
Status: Offline
Trenton Smith
1997 D90
Member
 
Join Date: Sep 2009
Location: Kerrville, Texas, USA
Posts: 84
When I blew my windshield wiper fuse, it killed all my gauges. These things are wired kinda nutty.
Reply With Quote
Sponsored Links
Advertisement
 
  #4  
Old January 27th, 2011, 02:58 PM
Hans's Avatar
Hans
Status: Offline
Hans Haase
The D-90.com Lab Rat
Member
 
Join Date: Oct 2003
Location: Long Island, NY
Posts: 2,381
There's two cables. One from the speedo head to the VSS transducer, then another from the transducer to the transfer case.

The transducer is under the truck, on top of the transfer case crossmember. Hard to spot unless you follow the cable, it's well hidden in there.

-Hans
__________________
My oil line fix

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
My 100k stopped odometer fix

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Brace for impact, I'm in a "modifying mood". Massive thread count inbound.
Reply With Quote
  #5  
Old January 27th, 2011, 03:14 PM
leastonce's Avatar
leastonce
Status: Offline
Jason England
D-90 White 95 SW #65
Site Team
 
Join Date: Jul 2009
Location: NYC
Posts: 6,078
Registry
Quote:
Originally Posted by Defender90_218 View Post
When I blew my windshield wiper fuse, it killed all my gauges. These things are wired kinda nutty.
in a 97 the speedo is electronic ... in a 94 and 95 it runs with a cable.

if you look on the frame under the drivers seat you'll find the cable, transducer and cable connecting to the transfer box. But i's definitely remove the speedo head and check that the cable spins when you drive ...

I repaired my cable with a $5 cable center from autozone ...
Reply With Quote
  #6  
Old June 1st, 2011, 06:45 PM
j0nny216's Avatar
j0nny216
Status: Offline
Jon Kleppel
1994 D90
Member
 
Join Date: Sep 2009
Location: Las Vegas, NV
Posts: 74
I need to revive this thread... I understand the two seperate cables and all that (I replaced my upper cable in Feb) but what are the two wires that go into the transducer? I tried to follow them but lose them somewhere in the engine bay. I parked my truck for 4 days and it was running fine, but when I started it up after it sat there the speedo was dead (the truck is a 1994 with 150xxx miles) and now the truck wants to stall every once in a while and it is just running crappy... any ideas? Oh and the check engine light came on, and I messed with some stuff, reset the ECU drove it a little bit, it stalled but the light has not come back on (yet).

Thanks Guys
Reply With Quote
Reply

Lower Navigation
Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions

Tags
speedo

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Speedometer / Odometer Not working TheBeast Defender Technical Discussions 4 June 13th, 2009 09:08 AM
Speedometer not working mgrgpg Defender Technical Discussions 4 June 11th, 2009 07:27 PM
VDO Speedometer Parts/Installation/Problems Merged Threads redrover Smaller Projects 86 March 7th, 2008 10:20 PM
Correcting speedometer after lift/tires Seriesman Defender Technical Discussions 16 November 24th, 2005 08:37 PM
?????? jimmy salmon Defender Technical Discussions 8 October 13th, 2005 11:54 AM


All times are GMT -5. The time now is 07:32 PM.


Copyright