Speedo Piinion Trouble - Defender Source
Defender Source  

Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions


Reply
 
Thread Tools
  #1  
Old June 7th, 2014, 05:18 PM
moose's Avatar
moose
Status: Offline
Brett
Ex-Mod Tdi 110 Hard Top
Member
 
Join Date: Mar 2007
Location: Mississauga, ON Canada
Posts: 259
Registry
Speedo Piinion Trouble

Yes, another speedo question, but this time it concerns the other end. My speedo stopped working. Assumed it was a busted cable. When I removed the cable I found that it was totally seized. Then, when I peered into where the cable attaches to the transfer box, I could see the bit where the square cable slides into was busted.





Looked through several manuals and the only info I could really find was this.

The following operation can be carried out with the gearbox in the vehicle...



Renew the speedometer drive pinion
1. Raise the vehicle on a ramp
2. Remove the speedometer drive clamp and nut and withdraw the cable
3. Prise out the drive pinion assembly
4. Push in a new assembly and fit the speedometer cable and secure with the clamp and nut.

OK, sounds easy enough but which part am I prying out and how exactly do I do that?

Any and all suggestions welcome.

Brett

__________________
Ex-Mod 110 Tdi
Series 3 88 Diesel Soft Top
Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old June 11th, 2014, 07:16 PM
moose's Avatar
moose
Status: Offline
Brett
Ex-Mod Tdi 110 Hard Top
Member
 
Join Date: Mar 2007
Location: Mississauga, ON Canada
Posts: 259
Registry
Well, thought I would update this post for posterity sake should some one, some day, do a search on the removing the speedo pinion and gear.


The manual says pry out the pinion. Easier said then done. Mine took lots penetrating oil followed by plenty of tapping, banging, hitting, levering and swearing until I was finally able to use some vise grips and remove the little bugger. Oh, and I also had to remove the parking brake backing plate to get some decent access to everything.








Funny thing is, that gear should be blue for a 110. Yellow is for a 90 with 205 x 16 tyres. I guess my 110 will be much faster once I get the proper gear in there.


Brett
__________________
Ex-Mod 110 Tdi
Series 3 88 Diesel Soft Top
Reply With Quote
Reply

Lower Navigation
Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions

Tags
speedo

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
LT 230 speedo drive to Smiths speedo o2batsea Series Technical Discussions 6 November 14th, 2011 01:22 PM
Trouble changing power steering belt, 94 D-90 Hans Defender Technical Discussions 13 October 8th, 2009 01:05 PM
Radiator Cooling Trouble mgrgpg Defender Technical Discussions 29 March 14th, 2005 05:43 PM
Trouble with getting profile info chrisvonc Support & Suggestions 2 February 4th, 2005 07:55 PM
Trouble Starting in the Rain Matt Klapmust Defender Technical Discussions 5 January 19th, 2004 04:53 PM


All times are GMT -5. The time now is 06:37 AM.


Copyright