Soft Brake Pedal Issue.... - Defender Source
Defender Source  

Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions


Reply
 
Thread Tools
  #1  
Old December 28th, 2007, 04:23 PM
greend90SW
Status: Offline
DLJ
1995 D90 SW #367
Member
 
Join Date: Feb 2004
Location: Florence, AL
Posts: 12
Soft Brake Pedal Issue....

I am experiencing a brake issue i am having difficulty running down. I am losing brake pressure after making any series of turns resulting in a soft pedal that goes approx. 1/3 to 1/2 way to the floorboard before getting any response from the brakes. The pedal responses normally on straightaway driving; ie no soft pedal, press=brakes, instead of press=wait for brakes (very unnerving).

I have dealt with almost the exact same problem before, which was loose front hub nuts, after replacing the front rotors. Pulled everything and retightened the hub nuts properly and issue was gone.

First thing i checked when this current brake problem arose was the hubs front and rear, all tight. My old land rover tech before i starting doing all the repair/maintenance myself suggested that the rubber brake lines at the swivel may have developed a bubble in the rubber causing a loss of pressure, checked those lines, all good.

I searched the forum and couldn't find anyone reporting a similar issue. I hope i have explained the problem well enough.

Any ideas guys? I am probably missing something simple.

DLJ

Follow-up Post:

A bit of info i left out. I did replace the wheel bearings when i replaced the front rotors. When i pulled apart the front hubs to check for hub nut tightness i also checked the new bearings on the drivers side and they looked normal, no scoring or signs of wear (had about 20-30 miles on them). I thought they might have been damaged from the prior loose hub nuts.
__________________
1995 D90 SW
367/500
Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old December 28th, 2007, 04:53 PM
jimmy salmon's Avatar
jimmy salmon
Status: Offline
jimmy salmon
94 D90 AA Yellow
Member
 
Join Date: Jun 2004
Location: Methuen MA USA
Posts: 1,342
did you replace the bearing right, if you have a wobble in a wheel it pushes the pads back resulting in a few pumps of the pedal to get pressure
__________________
3rd low and BOOT IT

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Reply With Quote
  #3  
Old December 28th, 2007, 05:20 PM
greend90SW
Status: Offline
DLJ
1995 D90 SW #367
Member
 
Join Date: Feb 2004
Location: Florence, AL
Posts: 12
Quote:
Originally Posted by jimmy salmon
did you replace the bearing right, if you have a wobble in a wheel it pushes the pads back resulting in a few pumps of the pedal to get pressure
The new bearings and races went back in the way the old ones came out.

Certainly i am aware that a wobble will push the pistons back and cause the need for double/triple pumps to push the pads back on the rotor, that was what was happening with the loose hub nuts after the rotors and bearings were replaced. I managed to diagnose and fix that instance of the soft pedal.

Thanks for the input Jimmy.
__________________
1995 D90 SW
367/500
Reply With Quote
Sponsored Links
Advertisement
 
  #4  
Old December 29th, 2007, 02:25 AM
imola's Avatar
imola
Status: Offline
John
97 D90 SW
Member
 
Join Date: Dec 2007
Location: NYC
Posts: 90
did you bleed the brakes as well? maybe try to bleed them again.
Reply With Quote
Reply

Lower Navigation
Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions

Tags
brake

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Clutch Master/Slave Cylinder Hydraulic Leak Merged Threadfest Buckon37s Defender Technical Discussions 223 September 1st, 2014 01:49 AM
Weird brake light issue on my 97 Please HELP! Cyborg Defender Technical Discussions 8 July 12th, 2009 01:04 PM
brake pedal mattdh Defender Technical Discussions 1 February 12th, 2005 05:35 PM
Brake pedal is hard!!?? Vadim Defender Technical Discussions 9 January 25th, 2005 01:09 PM
need wobbly brake pedal advice. januconn92 Defender Technical Discussions 6 May 24th, 2004 04:13 PM

» Defender Registry

110

RedRover02

Billy

Highseas
Add your Defender

All times are GMT -5. The time now is 02:09 PM.


Copyright