So I broke my speedo and I gotta fix it!! - Defender Source
Defender Source  

Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions


Reply
 
Thread Tools
  #1  
Old July 27th, 2009, 09:50 PM
RickM
Status: Offline
Rick Mabus
95 D-90 ST
Member
 
Join Date: Aug 2004
Location: Dallas, tx, Dallas
Posts: 330
So I broke my speedo and I gotta fix it!!

Alright. I have had one problem leading to another and this is starting wear me out. I somehow broke the key tumbler plastic stuff, and now after fixing that I then had to fix the starter I burned up, (just guess how that happened). NOW I need to fix my windshield washer fluid tank (somehow leaning on those to fix a starter is not good for it), and also most importantly fix my broken speedo cable. Sooooo, just how hard is it to replace one of those. It appears that the plastic bracket about 4 inches away from the gauge is where the problem starts. Also as a result of fixing my speedo cable what should I plan to break/fix next.........Any help would be most appreciated!!
Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old July 28th, 2009, 06:25 PM
Green Blood's Avatar
Green Blood
Status: Offline
Carl Phillips
1988 90- Swiss LHD 2.5 Petrol
Member
 
Join Date: Feb 2009
Location: Franklin, TN
Posts: 198
My speedo cable also broke just at the end where the plastic collar is crimped-on the cable. As a short-term, quick fix I cut a short piece of thick rubber tubing, slit it lengthwise and put it over the cable where the break was. After pushing the pieces together, I secured the tubing with two hose clamps. By clamping over the surface of the break it was able to hold the collar in place.

Sounds kind of complicated but was really easy and has been working great ever since.

I took photos to post but my camera is not with me. I'll post later in the week.

Cheers,

CARL
__________________
Proud restorer and former owner of '94 NAS D90 #590- back in the hands of its original owners.

And now happy owner of a 1988 Swiss-Market D90 Station Wagon.
Reply With Quote
  #3  
Old July 28th, 2009, 11:04 PM
RickM
Status: Offline
Rick Mabus
95 D-90 ST
Member
 
Join Date: Aug 2004
Location: Dallas, tx, Dallas
Posts: 330
Thanks for the update.

Thanks a ton for your reply. This sounds like a fix that I might be able to handle. I will look forward to the pics.
Reply With Quote
Reply

Lower Navigation
Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions

Tags
speedo

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 09:57 PM.


Copyright