small start up issue - Defender Source
Defender Source  

Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions


Reply
 
Thread Tools
  #1  
Old September 6th, 2015, 11:58 AM
kevincdoyle's Avatar
kevincdoyle
Status: Offline
Kevin C. Doyle
1995 NAS D90 Coniston Green SW
Member
 
Join Date: Nov 2003
Location: Tulsa, OK USA
Posts: 864
Registry
small start up issue

Hello Board-

Recently I have noticed when I go to start the 95 NAS 90, completely stock, after it initially starts, RPM's will drop down to almost nil, then catch and run perfectly normally.

It doesn't do it every time and the truck is rarely driven so I want to get ahead of any issue.

Could it be as simple as running a can of BG?

Not really a big deal just noticed it over the last few months. It never dies, just RPM's just drop then catch almost immediately.

Anyway, Happy Labor Day!

KCD
__________________
Attributed to Shayne...

"I actually like to paint some of my smaller parts......"
Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old September 6th, 2015, 02:09 PM
leastonce's Avatar
leastonce
Status: Offline
Jason England
D-90 White 95 SW #65
Site Team
 
Join Date: Jul 2009
Location: NYC
Posts: 6,078
Registry
Quote:
Originally Posted by kevincdoyle View Post
Hello Board- Recently I have noticed when I go to start the 95 NAS 90, completely stock, after it initially starts, RPM's will drop down to almost nil, then catch and run perfectly normally. It doesn't do it every time and the truck is rarely driven so I want to get ahead of any issue. Could it be as simple as running a can of BG? Not really a big deal just noticed it over the last few months. It never dies, just RPM's just drop then catch almost immediately. Anyway, Happy Labor Day! KCD
Air idle control valve or an air leak in a hose. My guess would be the big hose has started to rot unless it's been changed.
__________________
Quote:
Soapy water / KY jelly, etc. is is basically a must. Yes, good idea to remove trim panels - only takes 5 more minutes to do so.
Car Camping Collective founding member and Chief Executive Officer
Cat Camping Collective founding member and Chief Executive Officer
Reply With Quote
  #3  
Old September 6th, 2015, 10:38 PM
kevincdoyle's Avatar
kevincdoyle
Status: Offline
Kevin C. Doyle
1995 NAS D90 Coniston Green SW
Member
 
Join Date: Nov 2003
Location: Tulsa, OK USA
Posts: 864
Registry
Thanks Jason. I've seen a few references to the AICV and the hose is new.

I will check out the valve.

KCD
__________________
Attributed to Shayne...

"I actually like to paint some of my smaller parts......"
Reply With Quote
Sponsored Links
Advertisement
 
  #4  
Old September 6th, 2015, 10:58 PM
rijosho's Avatar
rijosho
Status: Offline
Joshua
1995 Black ST - Rhinolined edition
Research Assistant/Eagle Eyes
 
Join Date: Apr 2009
Location: NYC
Posts: 16,557
Registry
Quote:
Originally Posted by kevincdoyle View Post
Thanks Jason. I've seen a few references to the AICV and the hose is new. I will check out the valve. KCD
Just make sure you don't replace that hose with something that isn't 100% original!!
__________________
Quote:
I am talking purely from an aesthetics standpoint.
Reply With Quote
  #5  
Old September 7th, 2015, 09:06 AM
kevincdoyle's Avatar
kevincdoyle
Status: Offline
Kevin C. Doyle
1995 NAS D90 Coniston Green SW
Member
 
Join Date: Nov 2003
Location: Tulsa, OK USA
Posts: 864
Registry
Hah!

Quote:
Originally Posted by rijosho View Post
Just make sure you don't replace that hose with something that isn't 100% original!!
Never going to happen!

But I will research cleaning air idler valve and run a can of BG through first!

Thanks guys!
__________________
Attributed to Shayne...

"I actually like to paint some of my smaller parts......"
Reply With Quote
  #6  
Old October 9th, 2015, 09:18 PM
wmatos1001's Avatar
wmatos1001
Status: Offline
William
1994 NAS Defender 90
Member
 
Join Date: Aug 2014
Location: New Hampshire
Posts: 409
Registry
Kevin where did you get the air intake hose (big hose)? I can't seem to find them anywhere? I have determined mine has a leak and has been the bane of my existence.
Reply With Quote
  #7  
Old October 9th, 2015, 09:50 PM
kevincdoyle's Avatar
kevincdoyle
Status: Offline
Kevin C. Doyle
1995 NAS D90 Coniston Green SW
Member
 
Join Date: Nov 2003
Location: Tulsa, OK USA
Posts: 864
Registry
Quote:
Originally Posted by wmatos1001 View Post
Kevin where did you get the air intake hose (big hose)? I can't seem to find them anywhere? I have determined mine has a leak and has been the bane of my existence.
William, mine was new. There is a thread here somewhere about new ones. I'm hopeful Josh will chime in and show us the way..
__________________
Attributed to Shayne...

"I actually like to paint some of my smaller parts......"
Reply With Quote
  #8  
Old October 10th, 2015, 09:19 AM
wmatos1001's Avatar
wmatos1001
Status: Offline
William
1994 NAS Defender 90
Member
 
Join Date: Aug 2014
Location: New Hampshire
Posts: 409
Registry
Thanks, I ended up replacing the AICV versus cleaning but oddly mine was extremely easy to unscrew off. I practically could have done it by hand. But I definitely have a weak / rotted part of the big air hose that looks to be where unmonitored air is getting in and causing lean burn, odd idle (generally high) and occasional stall.

Amp and ignition coil all have been replaced and I'm getting code / check engine light #48.
Reply With Quote
Reply

Lower Navigation
Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions

Tags
start

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
300Tdi intermittent start issue - starter or main chassis ground? nathanwind Defender Technical Discussions 30 February 21st, 2015 10:04 PM
95' RRC No Start Issue Wolf Fabrication Defender Technical Discussions 16 November 2nd, 2012 02:39 PM
Gauges and Start Up Issue Defender_90 Defender Technical Discussions 2 April 13th, 2012 12:06 PM
89 Rover Classic no-start issue (not my own) Hans Defender Technical Discussions 7 March 28th, 2007 09:42 PM
95 won't start, possible fuel priming issue? jcasteel Defender Technical Discussions 1 March 15th, 2005 09:45 AM


All times are GMT -5. The time now is 10:27 AM.


Copyright