Rough idle, almost missing, cold weather seems worse - Defender Source
Defender Source  

Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions


Reply
 
Thread Tools
  #1  
Old January 6th, 2014, 08:45 PM
tebby's Avatar
tebby
Status: Offline
Justin Tebbenkamp
95 D-90 ST
Member
 
Join Date: May 2008
Location: Blacksburg, VA, USA
Posts: 274
Daily driver. Truck has always ran rich. Recently replaced fuel pump, filter, new battery. Other day, before replacing battery, very hard start. Let idle for almost 2 hours....afterwards ran very smooth. With this cold weather, idle has been awful....almost sounds like it's missing. Cranks right up with new battery but very rough with obvious loss of power. Does this sound like a vacuum issue? O2 issue? Cap/motor/wires/plugs approximately 5 years old. Does the 95 have a MAF or is that only the 97? Any suggestions much appreciated!
Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old January 6th, 2014, 10:34 PM
thewap's Avatar
thewap
Status: Offline
Marc
'95 D90 SW#106
Member
 
Join Date: Apr 2006
Location: Highmount, NY
Posts: 834
Registry
Would be good to start with new plugs, wires, cap, rotor , air filter, after 5 years. '95 has MAF, clean the MAF & connect. Are you throwing any codes?. Also check and clean coil wires, stepper motor...
Reply With Quote
  #3  
Old January 6th, 2014, 10:58 PM
evilfij's Avatar
evilfij
Status: Offline
evilfij
I have never seen a rover in person
Member
 
Join Date: Oct 2003
Location: on the internet
Posts: 14,688
I would start with cap/rotor/wires (and plugs). Check for vacuum leaks. Hole in the intake hose. Clean PCV etc. the easy cheap stuff to get a baseline. Any check engine lights? Could be the coolant temp sensor. That would explain the rich running and bad idle. What do you have in the way of spare you could throw at it? MAF you could eliminate by trying to start it with the MAF unplugged.
__________________
*not legal advice*
Reply With Quote
Reply

Lower Navigation
Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Rough Idle when engine is cold Jon_Winningham Defender Technical Discussions 2 May 10th, 2011 05:07 PM
Rough Idle @ Cold Start Grover Defender Technical Discussions 7 May 23rd, 2008 08:24 PM
Cold Weather Starter Problems boshea Defender Technical Discussions 9 October 25th, 2005 04:35 PM
1st really cold weather questions mspell Defender Technical Discussions 6 December 20th, 2004 08:40 PM
? for you cold weather people javelinadave Defender Technical Discussions 8 November 24th, 2004 12:34 PM


All times are GMT -5. The time now is 07:01 PM.


Copyright