Reverse light troubleshooting - Defender Source
Defender Source  

Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions


Reply
 
Thread Tools
  #1  
Old August 23rd, 2006, 09:12 AM
loykd's Avatar
loykd
Status: Offline
Ken Loy
1994 Portofino Red ST
Member
 
Join Date: Sep 2003
Location: Arlington, VA
Posts: 897
Reverse light troubleshooting

No, it's not the bulb. Connections at the light are all fine, as is the fuse. Any suggestions on where to look in my troubleshooting?
Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old August 23rd, 2006, 09:45 AM
tron's Avatar
tron
Status: Offline
Thomas F
Recently Roverless
Member
 
Join Date: Mar 2005
Location: Austin, TX, USA
Posts: 112
Probably not the problem, but mine was the casing/housing/cradle/grey plastic thingy, that the bulb plugs into. The leads on it were bad. You can just disconnect the old one and the new part is like $3 or something...if that is in fact the problem. Took me a while to figure it out (after replacing the bulb, looking at fuses, etc.).
Reply With Quote
  #3  
Old August 23rd, 2006, 09:52 AM
btate
Status: Offline
Bryan Tate
d90
Member
 
Join Date: Aug 2004
Location: Wilmington, NC
Posts: 479
Mine was the contacts for the bulb, a bit corroded. Are you getting power to the bulb assembly/wires?
Reply With Quote
Sponsored Links
Advertisement
 
  #4  
Old August 23rd, 2006, 10:26 AM
ne4x4's Avatar
ne4x4
Status: Offline
Ian McCormack
1984 Landrover 90
Member
 
Join Date: Nov 2005
Location: Durham, UK
Posts: 98
the reverse light switch in the gearbox could also be at fault or need adjusting or the connectors may have worked loose
__________________

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Reply With Quote
  #5  
Old August 23rd, 2006, 12:56 PM
loykd's Avatar
loykd
Status: Offline
Ken Loy
1994 Portofino Red ST
Member
 
Join Date: Sep 2003
Location: Arlington, VA
Posts: 897
I think Ian is on the right track. I shot wires at the bulb and I think they're ok. Just not getting the signal to turn on.
Reply With Quote
Reply

Lower Navigation
Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions

Tags
ht

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
how many forum members does it take to change a light bulb? brn24whl Misc. Chit-Chat 14 December 4th, 2009 09:07 AM
Diff-Lock Light Reverse Logic???? MonLand Defender Technical Discussions 5 December 5th, 2006 12:31 PM
ZF-4HP22 reverse slipping? kiphartzell Defender Technical Discussions 0 March 20th, 2006 09:30 PM
Help, no reverse light Glenn_Guinto Defender Technical Discussions 7 December 26th, 2003 04:17 PM
Reverse Light is Slow to Turn On-Why? JRowe Defender Technical Discussions 1 December 12th, 2003 05:03 PM


All times are GMT -5. The time now is 07:40 PM.


Copyright