Return of the No start has Spark no Pop - Defender Source
Defender Source  

Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions


Reply
 
Thread Tools
  #1  
Old December 9th, 2010, 12:52 PM
Coug D90's Avatar
Coug D90
Status: Offline
Tristan Felchlin
1995/D90
Member
 
Join Date: Jun 2010
Location: Little bit everywhere
Posts: 136
Return of the No start has Spark no Pop

So after completing the 2500 mile journey from Kentucky to Washington flawlessly (blown u joint the exception) i deemed it time for a little work. Oil change, all the fluids changed, transmission, t-case and diffs drained and refilled

Fast forward to the first drive post all the work, go to pull away from a light and it starts bucking and dies on the other side of the intersection... an embarrassing push by some jeep owners into a parking lot and about 10 minutes later fired right back up again and ran fine. Got it home and in the driveway, went to move it to diagnose and now nothing again.

I am getting spark at the plugs, and you can smell fuel, won't kick with started fluid even though..

New distributor cap, rotor, ignition module...

Pretty much stumped right now.

Appreciate the input.
Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old December 9th, 2010, 02:56 PM
Neil McCauley's Avatar
Neil McCauley
Status: Offline
Neil McCauley
94 ST, 97 ST, 93 110
Member
 
Join Date: Aug 2006
Location: Los Angeles
Posts: 2,366
Quote:
Originally Posted by Coug D90 View Post
So after completing the 2500 mile journey from Kentucky to Washington flawlessly (blown u joint the exception) i deemed it time for a little work. Oil change, all the fluids changed, transmission, t-case and diffs drained and refilled

Fast forward to the first drive post all the work, go to pull away from a light and it starts bucking and dies on the other side of the intersection... an embarrassing push by some jeep owners into a parking lot and about 10 minutes later fired right back up again and ran fine. Got it home and in the driveway, went to move it to diagnose and now nothing again.

I am getting spark at the plugs, and you can smell fuel, won't kick with started fluid even though..

New distributor cap, rotor, ignition module...

Pretty much stumped right now.

Appreciate the input.

I had a similiar problem, was intermitted, turned out when it would stall out, it was the fuel pump lead wire inside the chassis, it was shorting or corroded and would only go out sometimes, replaced it and its fine now.
__________________
A guy told me one time "don't let yourself get attached to anything you are not willing to walk out on in 30 seconds flat if you feel the heat from around the corner"

Robert Deniro
Reply With Quote
Reply

Lower Navigation
Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions

Tags
start

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
HELP 94 d90 will not start ripp2002 Defender Technical Discussions 64 August 25th, 2005 08:43 AM
No Spark Billakris Defender Technical Discussions 6 August 19th, 2005 12:01 AM
95 won't start, possible fuel priming issue? jcasteel Defender Technical Discussions 1 March 15th, 2005 09:45 AM
Rats! Now my D90 won't start. No power to fuel pump jcasteel Defender Technical Discussions 8 March 15th, 2005 09:42 AM
Non D90 Technical Question jump start polarity problem dnewman9 Defender Technical Discussions 4 September 6th, 2004 05:39 AM


All times are GMT -5. The time now is 07:00 PM.


Copyright