Repeatedly blowing undehood 30A fuse - Defender Source
Defender Source  

Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions

Join the Defender Source Community Today

Thread Tools
Old September 3rd, 2005, 03:18 PM
Hans's Avatar
Status: Offline
Hans Haase
The Lab Rat
Join Date: Oct 2003
Location: Long Island, NY
Posts: 2,385
Repeatedly blowing undehood 30A fuse

Ok, this is getting odd. I'm repeatedly blowing out the 30A under-hood fuse that's marked 'lighting' .

But every time it goes, I loose everything but the dash lights.

No power to the ECU, no power to the starter, no power to the distributor, no gauges.

But I can't figure out what the common connection is between the circuits.... unless maybe the ignition switch wires are on wrong, and it's using the lighting feed for the switch?


Follow-up Post:

Well, just tested every way I could think of and confirmed it.... The main fusebox under the hood on mine was wired backwards. The lighting fuse and ignition fuse wires are reversed at the box, so when I should have been going through a 60amp fuse it was going through the 30amp and probably just barely enough to fry it. My guess is that it's time for a new fuel filter and it's putting a bit more load on the pump, which makes sense since it always blew out during the first few seconds when the pump was priming the system for the first time.


Follow-up Post:

Scratch that, it's a short somewhere in the lighting circuit..... I'll deal with it tomorrow. At least it's narrowed down quite a lot for possible circuits.


My oil line fix

My 100k stopped odometer fix

Brace for impact, I'm in a "modifying mood". Massive thread count inbound.
Reply With Quote
Old September 6th, 2005, 03:24 PM
jaherring's Avatar
Status: Offline
Jason Herring
94 D90 ST #1253
Join Date: May 2004
Location: San Pedro, CA, USA
Posts: 561
I had a sticky starter relay that was blowing one of my 30A's underhood. New relay two weeks ago, no 'stuck-engaged' starter and no blown fuse (so far...)
Reply With Quote

Lower Navigation
Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions

hood, wing

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Fuel injection system Maxi fuse blowing ? TND90 Defender Technical Discussions 4 August 24th, 2009 11:32 AM
Blowing the gauge/brake light/blinker fuse R-C Defender Technical Discussions 3 May 20th, 2008 04:40 PM
Side lights fuse blowing owen Defender Technical Discussions 2 May 5th, 2008 09:59 AM
Fuel Pump Fuse Blows all the Time now! thug1313 Defender Technical Discussions 9 March 2nd, 2006 07:55 PM
Blowing wiper/speedo fuse like! P1CR Defender Technical Discussions 4 March 11th, 2004 03:23 PM

All times are GMT -5. The time now is 05:16 AM.