radio wiring help needed!! - Defender Source
Defender Source  

Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions


Reply
 
Thread Tools
  #1  
Old August 3rd, 2014, 07:33 PM
kevincdoyle's Avatar
kevincdoyle
Status: Offline
Kevin C. Doyle
1995 NAS D90 Coniston Green SW
Member
 
Join Date: Nov 2003
Location: Tulsa, OK USA
Posts: 863
Registry
radio wiring help needed!!

OK board, thought this was pretty straight forward but I guess not.

Factory radio/factory wiring harness etc.

gray plug on back of radio with 5 wires:

red/black
purple/gray
white/orange
black
yellow/purple

pink plug on back, 8 wires to speakers 2 each.

All of the wires matched up, annnddd....

Nada, no nothing from radio. the only really weird thing is that now my chime for seat belt and key left in ignition sounds like Elmer Fudd after doing Ether...a really slowwww drawn out chime, completely different from normal... any thoughts?

Thanks!

KCD
__________________
Attributed to Shayne...

"I actually like to paint some of my smaller parts......"
Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old August 3rd, 2014, 07:52 PM
the rover shop
Status: Offline
shayne young
89,93 & 95 camel trophy 110s 06 130
Member
 
Join Date: Sep 2011
Location: ft lauderdale florida
Posts: 5,225
Radios nowadays need... Constant power...(usually yellow). Ignition switched power..(usually red) ground..(usually black) A remote on wire..(usually blue)..(supplies power out when radio is switched on..usually to turn on an amplifier.) and an illumination light signal (wanna say usually orange) (power when lights turned on..(or dims radio when lights turned on),..
I checked my factory light diagram and it doesn't match up with what you wrote..the two plugs sound like what is on a discovery 1 radio.. Will check tomorrow if you still need it..
Reply With Quote
  #3  
Old August 3rd, 2014, 08:00 PM
rankar's Avatar
rankar
Status: Offline
Randy
97 SW #2236 (Maggie)
Member
 
Join Date: Aug 2013
Location: CT
Posts: 1,117
Registry
Sounds like a short. Take the radio out, put it on your bench, and connect a power supply to it to test. If ok, then use the same harness to test it again. If ok, then go through the car connectors for the short.

Then test with no loads (no speakers connected at the harness)
Reply With Quote
Sponsored Links
Advertisement
 
  #4  
Old August 3rd, 2014, 08:05 PM
kevincdoyle's Avatar
kevincdoyle
Status: Offline
Kevin C. Doyle
1995 NAS D90 Coniston Green SW
Member
 
Join Date: Nov 2003
Location: Tulsa, OK USA
Posts: 863
Registry
getting closer...

Quote:
Originally Posted by the rover shop View Post
Radios nowadays need... Constant power...(usually yellow). Ignition switched power..(usually red) ground..(usually black) A remote on wire..(usually blue)..(supplies power out when radio is switched on..usually to turn on an amplifier.) and an illumination light signal (wanna say usually orange) (power when lights turned on..(or dims radio when lights turned on),..
I checked my factory light diagram and it doesn't match up with what you wrote..the two plugs sound like what is on a discovery 1 radio.. Will check tomorrow if you still need it..
OK first of all something weird.

Checked fuses and the hazard fuse was glowing red, someone put a 20 amp in. Replaced it with a 15 amp and now everything sounds and looks normal. Radio comes on but won't accept code, any other thoughts?

Scouring the neighborhood for a Night Ranger cassette to see if it will take cassette....
__________________
Attributed to Shayne...

"I actually like to paint some of my smaller parts......"
Reply With Quote
  #5  
Old August 3rd, 2014, 08:17 PM
rankar's Avatar
rankar
Status: Offline
Randy
97 SW #2236 (Maggie)
Member
 
Join Date: Aug 2013
Location: CT
Posts: 1,117
Registry
Try to unplug harness and hold the power button down for ten seconds. Reconnect harness, enter code, and crank sister Christian on full blast!
Reply With Quote
  #6  
Old August 3rd, 2014, 08:33 PM
kevincdoyle's Avatar
kevincdoyle
Status: Offline
Kevin C. Doyle
1995 NAS D90 Coniston Green SW
Member
 
Join Date: Nov 2003
Location: Tulsa, OK USA
Posts: 863
Registry
dammit, no go.....

Quote:
Originally Posted by rankar View Post
Try to unplug harness and hold the power button down for ten seconds. Reconnect harness, enter code, and crank sister Christian on full blast!

screen lights up and everything, just will not accept code, just the 4 lines across...

any other thoughts other than 4X4 radio?

trying to sing me away, nothin' happening....
__________________
Attributed to Shayne...

"I actually like to paint some of my smaller parts......"
Reply With Quote
  #7  
Old August 3rd, 2014, 08:42 PM
rankar's Avatar
rankar
Status: Offline
Randy
97 SW #2236 (Maggie)
Member
 
Join Date: Aug 2013
Location: CT
Posts: 1,117
Registry
Yes make sure your battery is putting full voltage out. Radio won't accept code if is battery low.

Try turning the engine on, let it run for a minute, then try.
Reply With Quote
  #8  
Old August 3rd, 2014, 08:42 PM
Viton's Avatar
Viton
Status: Offline
Deaf Ember
Smart 4x4
Member
 
Join Date: Jan 2009
Location: La
Posts: 1,231
This is what I replaced mine with, it's actually made by Jensen.

http://www.ebay.com/itm/New-Ford-Tra...item4ac83ae196

http://www.aiproducts.com/techbullet...440ENGLISH.pdf
Reply With Quote
  #9  
Old August 3rd, 2014, 09:13 PM
carlosz's Avatar
carlosz
Status: Offline
Carlos
frank stein "frankie" in action RIP
Member
 
Join Date: Jun 2006
Location: east coast
Posts: 962
Registry
the 12volt.com...your radio wiring friend...
Reply With Quote
  #10  
Old August 3rd, 2014, 09:50 PM
kevincdoyle's Avatar
kevincdoyle
Status: Offline
Kevin C. Doyle
1995 NAS D90 Coniston Green SW
Member
 
Join Date: Nov 2003
Location: Tulsa, OK USA
Posts: 863
Registry
tried that....

Quote:
Originally Posted by rankar View Post
Yes make sure your battery is putting full voltage out. Radio won't accept code if is battery low.

Try turning the engine on, let it run for a minute, then try.
I'm about 99.9% sure it is wired correctly, radio lights come on, dim, etc when I put on headlights and parking lights.

Even got a little bit of noise from all four speakers when I plugged in pink speaker plug.

It's just not accepting any numbers when I push them to enter code.

Guess I'll have battery checked as a first line to shipping off.

Damn, hours on this and I thought I had it...

On a positive note, it looks effin awesome!!

I'll do a few more searches and see if I'm supposed to face East or West and say some sort of Lucas incantation...

Thanks for all the quick help guys!!
__________________
Attributed to Shayne...

"I actually like to paint some of my smaller parts......"
Reply With Quote
  #11  
Old August 3rd, 2014, 09:53 PM
rankar's Avatar
rankar
Status: Offline
Randy
97 SW #2236 (Maggie)
Member
 
Join Date: Aug 2013
Location: CT
Posts: 1,117
Registry
Still try to pull it out and bench test. Gotta hear some night ranger over here
Reply With Quote
  #12  
Old August 3rd, 2014, 10:12 PM
kevincdoyle's Avatar
kevincdoyle
Status: Offline
Kevin C. Doyle
1995 NAS D90 Coniston Green SW
Member
 
Join Date: Nov 2003
Location: Tulsa, OK USA
Posts: 863
Registry
Wooooo hoooooo!!!! Success!!!!!!!!!!!!!!!!!!!!!!!

Believe it not Board, SEARCH WORKS!!!!

I read through quite a few posts about codes and found a few about holding BND button down for 5 seconds..

Went back out there in the pitch dark to try it and SUCCESS!!!!

Sounds awesome! I'm overly excited according to my daughters..

(they wanted to know what a cassette was)

Night Ranger.....coming uppp!!

Thanks again so much guys!!

KCD
__________________
Attributed to Shayne...

"I actually like to paint some of my smaller parts......"
Reply With Quote
  #13  
Old August 3rd, 2014, 10:29 PM
rankar's Avatar
rankar
Status: Offline
Randy
97 SW #2236 (Maggie)
Member
 
Join Date: Aug 2013
Location: CT
Posts: 1,117
Registry
Bitchin. Now crank it!
Reply With Quote
  #14  
Old August 13th, 2014, 10:19 AM
nflory's Avatar
nflory
Status: Offline
Nate
1997/Defender 90 ST
Member
 
Join Date: Dec 2013
Location: Manhattan Beach
Posts: 76
I can't get the code off my radio. Going to replace it for now. Does anyone know if the wiring harness for the 1997 disco will fit the D90 wiring? I would rather not cut original defender harness to put in aftermarket radio. Thanks
Reply With Quote
  #15  
Old August 13th, 2014, 10:22 AM
the rover shop
Status: Offline
shayne young
89,93 & 95 camel trophy 110s 06 130
Member
 
Join Date: Sep 2011
Location: ft lauderdale florida
Posts: 5,225
Buy the adaptor harness.. Read the first couple of responses in this thread..
Reply With Quote
  #16  
Old August 13th, 2014, 10:30 AM
nflory's Avatar
nflory
Status: Offline
Nate
1997/Defender 90 ST
Member
 
Join Date: Dec 2013
Location: Manhattan Beach
Posts: 76
Rover shop. I am not seeing where to buy the adapter harness. Maybe I am missing something.
Reply With Quote
  #17  
Old August 13th, 2014, 11:04 AM
rankar's Avatar
rankar
Status: Offline
Randy
97 SW #2236 (Maggie)
Member
 
Join Date: Aug 2013
Location: CT
Posts: 1,117
Registry
Check to see if Metra Harnesses has one
Reply With Quote
  #18  
Old August 13th, 2014, 11:45 AM
the rover shop
Status: Offline
shayne young
89,93 & 95 camel trophy 110s 06 130
Member
 
Join Date: Sep 2011
Location: ft lauderdale florida
Posts: 5,225
Type into eBay rover radio harness or adaptor and you can make sure they have the right plugs for your application by the pics.. Cheap as..... And fast shipping.. If not I'm sure I probably have some laying around if you are in a hurry... But hard to beat the speed of eBay... Even from china lately..
Reply With Quote
  #19  
Old August 13th, 2014, 02:58 PM
nflory's Avatar
nflory
Status: Offline
Nate
1997/Defender 90 ST
Member
 
Join Date: Dec 2013
Location: Manhattan Beach
Posts: 76
Thanks folks. I check metra and doesn't look like they have it. Anyone know if this was the same head unit/harness as any other rover that year? Thanks
Reply With Quote
  #20  
Old August 13th, 2014, 03:03 PM
the rover shop
Status: Offline
shayne young
89,93 & 95 camel trophy 110s 06 130
Member
 
Join Date: Sep 2011
Location: ft lauderdale florida
Posts: 5,225
I see you are from Idaho.. That reminds me of a joke .. Anybody know why there was only 51 contestants in the Miss Ebonics USA contest...???
Reply With Quote
Reply

Lower Navigation
Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions

Tags
radio, wiring

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
ignition wiring help needed.. kevincdoyle Defender Technical Discussions 2 January 19th, 2014 10:49 PM
ignition wiring help needed spartan Defender Technical Discussions 3 June 26th, 2013 02:13 PM
Speaker Wiring Help Needed NoVaKevin Defender Technical Discussions 10 February 14th, 2011 02:49 PM
radio wiring harness adapter for aftermarket radio mightymg Wanted 8 March 25th, 2010 02:56 PM
Radio install/wiring help needed. Firefighter2904 Defender Technical Discussions 5 August 8th, 2007 09:39 PM


All times are GMT -5. The time now is 01:47 AM.


Copyright