Pulling my hair out with handling issue - Page 2 - Defender Source
Defender Source  

Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions


Reply
 
Thread Tools
  #21  
Old February 19th, 2010, 08:56 AM
TDI Guy's Avatar
TDI Guy
Status: Offline
Randy
2015 LR4
D-90 Source Vendor
 
Join Date: Sep 2003
Location: NJ
Posts: 4,573
Registry
I would check the rear links and a-arm bushings. Also, have a shop do the alignment.. Leave that stuff to a shop. Where in NY are you. I have a great place in Maywood NJ for that.. He has done plenty of d-90's

Is there any strange noises? knocking?
__________________
Legend in My Own Mind.
Reply With Quote
Sponsored Links
Advertisement
 
  #22  
Old February 19th, 2010, 09:55 AM
Davis's Avatar
Davis
Status: Offline
Chris Davis
94 NAS D90 6.2LS
Member
 
Join Date: Nov 2003
Location: Colorado
Posts: 2,500
I have a slight veer when I get on/off the gas--it has plagued me for years but not serious enough to replace any of my A-arm components which are the only thing I have not replaced (and which all seem tight and good, even with a bar prying on them to check for play). That said, I am running a detroit in back and tru-track in front and I am thinking when I get on/off the gas, the lockers in that situation bias power to one axle shaft which may certainly explain it.

That said, I would check both your diffs and see if you possibly have a broken axle shaft or bad diff--that would certainly have some of the symptoms you are referring to. Assuming all your suspension bushing are in OK situation, this or the a-arm is the only thing that makes sense to me. I don't see this as being a pre-load swivel issue but that is worth checking for maintenance sake.
Reply With Quote
  #23  
Old February 19th, 2010, 10:03 AM
TDI Guy's Avatar
TDI Guy
Status: Offline
Randy
2015 LR4
D-90 Source Vendor
 
Join Date: Sep 2003
Location: NJ
Posts: 4,573
Registry
Rear link bushings at the chassis??
__________________
Legend in My Own Mind.
Reply With Quote
Reply

Lower Navigation
Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Pulling a Trailer/RV michael15 Defender Technical Discussions 18 February 27th, 2006 07:47 AM
Clutch issue? Help with diagnosis..... Hans Defender Technical Discussions 13 December 18th, 2005 05:19 PM
95 won't start, possible fuel priming issue? jcasteel Defender Technical Discussions 1 March 15th, 2005 09:45 AM
strange heat issue jabber Defender Technical Discussions 15 March 6th, 2005 05:42 PM
Driveshaft Issues Continue...?? P1CR Defender Technical Discussions 9 July 22nd, 2004 09:12 PM


All times are GMT -5. The time now is 11:17 PM.


Copyright