Power Steering Not working - Defender Source
Defender Source  

Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions


Reply
 
Thread Tools
  #1  
Old June 15th, 2016, 09:37 AM
TDI Guy's Avatar
TDI Guy
Status: Offline
Randy
2015 LR4
D-90 Source Vendor
 
Join Date: Sep 2003
Location: NJ
Posts: 4,573
Registry
Power Steering Not working

putting together a 300tdi with 50k miles on it. Installed the lines and a new steering box. Started it up and later noticed that the power steering is not working. fluid is topped off. Could the PS pump go bad? I never had a PS pump go bad so was just wondering if I should check anything or how to test things before ordering a new pump.
__________________
Legend in My Own Mind.
Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old June 15th, 2016, 09:41 AM
Kevin88RRC's Avatar
Kevin88RRC
Status: Offline
Kevin Keith
1988 RRC
Member
 
Join Date: Dec 2014
Location: Portland, Maine
Posts: 1,045
Did you bleed the air out?
Reply With Quote
  #3  
Old June 15th, 2016, 09:52 AM
AdamSanta85's Avatar
AdamSanta85
Status: Offline
Adam
91' D90 200TDI
Member
 
Join Date: Apr 2016
Location: Sayville, NY
Posts: 1,524
Registry
Quote:
Originally Posted by TDI Guy View Post
putting together a 300tdi with 50k miles on it. Installed the lines and a new steering box. Started it up and later noticed that the power steering is not working. fluid is topped off. Could the PS pump go bad? I never had a PS pump go bad so was just wondering if I should check anything or how to test things before ordering a new pump.
Take the reservoir cap off, with car running and turn the wheel left and right and see if the fluid level drops. Keep topping off.
Reply With Quote
Sponsored Links
Advertisement
 
  #4  
Old June 15th, 2016, 09:55 AM
o2batsea's Avatar
o2batsea
Status: Offline
Bill Adams
66 109 sw 94 lwb
Member
 
Join Date: Jul 2009
Location: kensington md
Posts: 6,503
Registry
I ordered a new pump recently. I recall they weren't too expensive from LR Direct. I wouldn't use a questionable pump considering the hell you'd have to go thru to replace one once the engine is in.
__________________
Bill Adams

1966 109 5 door wagon 300Tdi "spermaceti fueled"
1994 RRC LeWiB "ruining the air behind me"
1968 2A 88

All my troubles are Rover
Reply With Quote
  #5  
Old June 15th, 2016, 09:56 AM
Naplm00
Status: Offline
Matthew
1983 110 200tdi 3 door soft top
Member
 
Join Date: Sep 2010
Location: San Jose, California
Posts: 2,863
As these guys said, you may just have an air locked system. There is also a air bleed screw on top of some of the boxes
Reply With Quote
  #6  
Old June 15th, 2016, 10:06 AM
TDI Guy's Avatar
TDI Guy
Status: Offline
Randy
2015 LR4
D-90 Source Vendor
 
Join Date: Sep 2003
Location: NJ
Posts: 4,573
Registry
I have went lock to lock a shit load of times. No luck. In the past that's all I did but this time nothing.
__________________
Legend in My Own Mind.
Reply With Quote
  #7  
Old June 15th, 2016, 10:18 AM
o2batsea's Avatar
o2batsea
Status: Offline
Bill Adams
66 109 sw 94 lwb
Member
 
Join Date: Jul 2009
Location: kensington md
Posts: 6,503
Registry
ZF pump is $89.34 shipped from LR Direct. I wouldnt wait a moment and order one up.
__________________
Bill Adams

1966 109 5 door wagon 300Tdi "spermaceti fueled"
1994 RRC LeWiB "ruining the air behind me"
1968 2A 88

All my troubles are Rover
Reply With Quote
  #8  
Old June 15th, 2016, 10:21 AM
Naplm00
Status: Offline
Matthew
1983 110 200tdi 3 door soft top
Member
 
Join Date: Sep 2010
Location: San Jose, California
Posts: 2,863
With the engine be running do you get any fluid movement in the reservoir? Also a messy test is to pull off the high pressure line at the box input and see if it sprays hard when Turing... This was you know it's not the box
Reply With Quote
  #9  
Old June 15th, 2016, 10:33 AM
TDI Guy's Avatar
TDI Guy
Status: Offline
Randy
2015 LR4
D-90 Source Vendor
 
Join Date: Sep 2003
Location: NJ
Posts: 4,573
Registry
I'm mistake. It's a td5 not 300tdi. I don't see the td5 pump on LR direct
__________________
Legend in My Own Mind.
Reply With Quote
  #10  
Old June 15th, 2016, 10:37 AM
Kevin88RRC's Avatar
Kevin88RRC
Status: Offline
Kevin Keith
1988 RRC
Member
 
Join Date: Dec 2014
Location: Portland, Maine
Posts: 1,045
Quote:
Originally Posted by Naplm00 View Post
As these guys said, you may just have an air locked system. There is also a air bleed screw on top of some of the boxes
Here you go...
Attached Thumbnails
Click image for larger version

Name:	Workshop Manual SRR652USWM A.jpg
Views:	56
Size:	97.2 KB
ID:	151984  
Attached Files
File Type: pdf Workshop Manual SRR652USWM A.pdf (81.2 KB, 8 views)
Reply With Quote
  #11  
Old June 15th, 2016, 12:12 PM
o2batsea's Avatar
o2batsea
Status: Offline
Bill Adams
66 109 sw 94 lwb
Member
 
Join Date: Jul 2009
Location: kensington md
Posts: 6,503
Registry
I'm probably wrong but it looks like the same pump to me. I have zero td5 experience.
__________________
Bill Adams

1966 109 5 door wagon 300Tdi "spermaceti fueled"
1994 RRC LeWiB "ruining the air behind me"
1968 2A 88

All my troubles are Rover
Reply With Quote
  #12  
Old June 16th, 2016, 09:23 AM
TDI Guy's Avatar
TDI Guy
Status: Offline
Randy
2015 LR4
D-90 Source Vendor
 
Join Date: Sep 2003
Location: NJ
Posts: 4,573
Registry
Td5 pump is different for sure. I had no time to to try to bleed it yesterday. I will try one more time then Im guessing the pump.
__________________
Legend in My Own Mind.
Reply With Quote
  #13  
Old June 16th, 2016, 09:29 AM
Naplm00
Status: Offline
Matthew
1983 110 200tdi 3 door soft top
Member
 
Join Date: Sep 2010
Location: San Jose, California
Posts: 2,863
Hey I'm free if you want some help, pm me
Reply With Quote
  #14  
Old June 17th, 2016, 07:58 AM
TDI Guy's Avatar
TDI Guy
Status: Offline
Randy
2015 LR4
D-90 Source Vendor
 
Join Date: Sep 2003
Location: NJ
Posts: 4,573
Registry
No air in system. Im guessing the pump is bad. does not appear to have any pressure.
__________________
Legend in My Own Mind.
Reply With Quote
  #15  
Old June 17th, 2016, 09:09 AM
Naplm00
Status: Offline
Matthew
1983 110 200tdi 3 door soft top
Member
 
Join Date: Sep 2010
Location: San Jose, California
Posts: 2,863
Bummer man, maybe go the s10 pump route? Crap that's for 300 unknown if it works on td5
Reply With Quote
  #16  
Old June 17th, 2016, 10:30 AM
TDI Guy's Avatar
TDI Guy
Status: Offline
Randy
2015 LR4
D-90 Source Vendor
 
Join Date: Sep 2003
Location: NJ
Posts: 4,573
Registry
Td5 is a special pump it drives the water pump as well.
__________________
Legend in My Own Mind.
Reply With Quote
  #17  
Old June 17th, 2016, 10:47 AM
rdavisinva's Avatar
rdavisinva
Status: Offline
Robert Davis
N/A
Member
 
Join Date: Oct 2004
Location: USA
Posts: 6,798
slightly loosen the pressure line and see if it leaks pressurized fluid.
Are you 100% sure you have the lines routed correctly?
__________________
RDavisinVA

Uncle "Richard" Douglas has a Land Rover with big wheels that never gets stuck... until he breaks something so it won't go. Uncle Douglas always breaks something. - Anna Crowther at the Conclave 2012 (AKA Carburetor Neck)

"What's with this death wobble, Uncle Douglas, I can't keep it in 1 lane?"
UD: "Just Power through it man!"
Reply With Quote
  #18  
Old June 29th, 2016, 03:54 PM
TDI Guy's Avatar
TDI Guy
Status: Offline
Randy
2015 LR4
D-90 Source Vendor
 
Join Date: Sep 2003
Location: NJ
Posts: 4,573
Registry
Ended up replacing the pump and all is well. Never had a faulty pump with no signs of failure.
__________________
Legend in My Own Mind.
Reply With Quote
Reply

Lower Navigation
Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Power Steering fluid not red but pink- Tyler Wirken Defender Technical Discussions 3 August 6th, 2012 10:51 PM
Speedometer not working mgrgpg Defender Technical Discussions 4 June 11th, 2009 07:27 PM
My headlights are not working woldd90 Defender Technical Discussions 13 December 2nd, 2005 10:49 AM
'95 Factory Radio Fade/Treble/Bass Button Not Working gamberik Defender Technical Discussions 1 March 30th, 2005 01:05 PM
Fan blower switch not working draaronr Defender Technical Discussions 3 August 24th, 2004 11:26 AM


All times are GMT -5. The time now is 05:24 AM.


Copyright