Odd electrical behavior - Defender Source
Defender Source  

Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions


Reply
 
Thread Tools
  #1  
Old April 25th, 2015, 05:53 PM
pitchrollyaw's Avatar
pitchrollyaw
Status: Offline
wayne p
1985 d90 2.5NA
Member
 
Join Date: Aug 2013
Location: Hopkinton, MA USA
Posts: 316
Registry
Odd electrical behavior

I have an odd set of symptoms, and looking for thoughts. Pretty sure it is a bad alternator, but it is a new manufactured 1 yr old unit (not that means much these days...). I know just enough about basic auto electronics to be dangerous.

1 yr old replacement alternator, running fine until last night. Got a single flicker on the battery light idling in traffic, noticed voltage read lower (but within the black) at cruise after and my VDO oil pressure gauge seemed to read higher than normal. The lower voltage reading then became erratic, still staying in the black. I got home and then loaded the alternator w/ fan, lights, etc which brought the voltage down, and it never recovered even with high RPM's.

Now the weird part. I shut the truck down, go to start it again and but no battery light unless I turn to the glow plug position!?! Also noticed that the new belt was very loose...was sufficiently tight not that long ago, can see the loose belt causing the erratic voltage, but not the no battery light.

Probably will not have time to pull the alt for a few days...
__________________
'85 90 2.5NA
'72 SIII 88"
Couple other cars
..tolerant Wife...
Reply With Quote
Sponsored Links
Advertisement
 
Reply

Lower Navigation
Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions

Tags
electrical

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
odd electrical issue - anyone seen this one? akrockhound Defender Technical Discussions 2 December 24th, 2013 05:31 PM
An Odd Vibration Weldon Defender Technical Discussions 5 May 7th, 2006 02:41 PM
Odd price difference flippedrover Misc. Chit-Chat 5 August 2nd, 2005 08:15 PM
Odd intake compatibility question for Rover Tech types Hans Defender Technical Discussions 3 December 13th, 2004 07:39 PM
94 hella edition colors -7 odd balls evilfij Misc. Chit-Chat 12 June 17th, 2004 06:52 PM


All times are GMT -5. The time now is 06:41 AM.


Copyright