O2 Sensor Problem? - Defender Source
Defender Source  

Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions


Reply
 
Thread Tools
  #1  
Old May 18th, 2009, 01:32 PM
GYM's Avatar
GYM
Status: Offline
Gary
97 SW
Member
 
Join Date: Jul 2006
Location: West Coast
Posts: 1,062
O2 Sensor Problem?

Over the past few months, gas mileage has dropped from 12 to 9.5. (97 NAS ST, stock 4.0 gas, 61,000 miles.)

Merging into freeway traffic yesterday, was surprised to see black smoke billowing from the exhaust at full throttle.

No CEL. Truck is not overheating. No rattling coming from cats or muffler and no damage to exhaust system. 60,000 mile service done on schedule. Idles fine. Truck seems to drive fine.

After searching the topic here; I am thinking that the run rich condition and reduced mileage may be one or more faulty 02 sensors.

Any thoughts? Any other possibilities? (ie: VSS?)

Thanks very much.
Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old May 18th, 2009, 01:36 PM
evilfij's Avatar
evilfij
Status: Offline
evilfij
I have never seen a rover in person
Member
 
Join Date: Oct 2003
Location: on the internet
Posts: 14,688
MAF is the other possibility.
__________________
*not legal advice*
Reply With Quote
  #3  
Old August 17th, 2009, 10:16 AM
rover4x4's Avatar
rover4x4
Status: Offline
Phillip
1995 SW #487/500
Member
 
Join Date: Sep 2003
Location: The Old North State
Posts: 7,527
Registry
I occasionally get some black or grey smoke if I stand in the gas. I am getting 14-15 to the gallon with 255's and I dont pussy foot around. Is this carbon in the top end or fueling issues. 75k with no issues to speak of, the truck is strong. Ive replaced a few things vac advance an o2 sensor because I robbed them to fix my classic.
__________________
Poor gas mileage gets you to the best places on earth
Reply With Quote
Reply

Lower Navigation
Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions

Tags
sensor

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
O2 Sensor troubleshoot floatflyer Defender Technical Discussions 2 November 7th, 2009 09:34 PM
110 Kills Multiple O2 Sensors pcscharfe Defender Technical Discussions 8 May 20th, 2009 10:19 AM
O2 Sensor Removal w/ LRT-12-047 pcscharfe Defender Technical Discussions 9 November 13th, 2008 12:30 PM
Anyone shear an O2 Sensor Ragland Defender Technical Discussions 2 May 24th, 2004 08:37 PM
O2 sensors J4hand Defender Technical Discussions 0 January 8th, 2004 02:39 PM


All times are GMT -5. The time now is 12:15 PM.


Copyright