No start only click 2.5na - Page 2 - Defender Source
Defender Source  

Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions


Reply
 
Thread Tools
  #21  
Old October 20th, 2015, 10:56 PM
redline_r
Status: Offline
Ridwan
1986/Land Rover 110
Member
 
Join Date: Jul 2015
Location: Atlanta, GA
Posts: 89
Cleaned contacts, still no luck.

On the 86 onwards diagram I see a starter relay, but just cannot find this physical object!
Reply With Quote
Sponsored Links
Advertisement
 
  #22  
Old October 20th, 2015, 11:52 PM
Daddymow's Avatar
Daddymow
Status: Offline
Raub A.
1987 D110 Tithonus
Member
 
Join Date: Oct 2011
Location: Stuart, FL / Boone, NC
Posts: 3,973
Registry
Well, obviously time to pull that lump of shit out of your engine bay and put in a 200Tdi. Or an om617. Or an Ls1. Or some hamsters on a wheel, anything would make your truck much more drivable than that 2.5 N/A/POS.
__________________
You can't polish a turd but you can roll it in glitter - eBay.uk ad for Freelander.
Reply With Quote
  #23  
Old October 21st, 2015, 01:32 AM
Ignotus
Status: Offline
gene
1960 109, w/200TDI
Member
 
Join Date: Sep 2012
Location: 3rd rock from the Sun
Posts: 401
Have you tried, making a jumper for the wire soleniod spade terminal and having just a bare wire on the other end then touching the + wire at the starter with it? Even with the key off the starter should turn so be careful and have it out of gear. Doing this bypasses the ignition and can give a clue to wether the soleniod or the small ign wire are bad.
Have you checked with a test lamp you are getting power to the ign/starter wires when key is in ign position?
Is the + wire on the starter tight?
__________________
Gene
1960 109
1960 88 Ignotus
Blog;
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Reply With Quote
Sponsored Links
Advertisement
 
  #24  
Old October 21st, 2015, 02:13 AM
javelinadave
Status: Offline
-
-
Member
 
Join Date: Sep 2003
Location: -
Posts: 5,394
I too had this same issue after The paint was baking soda blamed from my ExMOD 90. I hit the starter, solenoid, the relays behind the fuse panel and the ignition switch with compressed air. It cured the problem.
Reply With Quote
Reply

Lower Navigation
Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions

Tags
start

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Start no start leastonce Defender Technical Discussions 10 February 25th, 2012 02:33 PM
WTS: 2.5na diesel engine (in CANADA) headdamage For Sale - Parts 2 April 1st, 2008 04:36 PM
Turn the key and . . . CLICK! Bozman Defender Technical Discussions 15 January 25th, 2007 02:57 PM
Won't start...only when it rains gravitysucks Defender Technical Discussions 8 January 4th, 2006 12:07 PM
Click...Click...Click... bjenk Defender Technical Discussions 10 February 15th, 2005 09:05 PM


All times are GMT -5. The time now is 07:56 AM.


Copyright