No start - Page 3 - Defender Source
Defender Source  

Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions


Reply
 
Thread Tools
  #41  
Old August 20th, 2010, 03:43 PM
cgalpin's Avatar
cgalpin
Status: Offline
Charles Galpin
'94 D90 ST, '63 SeriesIIA
Site Team
 
Join Date: Jan 2004
Location: South Riding, VA
Posts: 11,625
Registry
Tick is gone. Won't be time to mess with it until next week, but once I get the ignition module and distributor all buttoned up I'll give her a nice ride and see how I feel about it. I did stick my finger into the drain hole and could feel a bit of gunk down there, but this was also a cold oil change. I expect changing the oil at operating temps will clean it out well enough. Not afraid to waste some oil and filters and give it a few quick oil changes.

thanks,
charles
Reply With Quote
Sponsored Links
Advertisement
 
  #42  
Old August 20th, 2010, 03:51 PM
The Dro
Status: Offline
Dro
1988 Ninety
Member
 
Join Date: Jan 2010
Location: Annandale, VA
Posts: 6,689
Registry
Quote:
Originally Posted by cgalpin View Post
Tick is gone. Won't be time to mess with it until next week, but once I get the ignition module and distributor all buttoned up I'll give her a nice ride and see how I feel about it. I did stick my finger into the drain hole and could feel a bit of gunk down there, but this was also a cold oil change. I expect changing the oil at operating temps will clean it out well enough. Not afraid to waste some oil and filters and give it a few quick oil changes.

thanks,
charles
I have a few new oil filters if you need them.
Reply With Quote
  #43  
Old August 20th, 2010, 04:05 PM
CDN90's Avatar
CDN90
Status: Offline
Tim
94 / D90 #79
Member
 
Join Date: Aug 2009
Location: Vancouver,B.C.,Canada
Posts: 135
Very Nice to hear she's running! I have been following the thread and now can say congratz! Enjoy.

Oh by the way testing forum runner. Nice app!
Reply With Quote
Sponsored Links
Advertisement
 
  #44  
Old August 20th, 2010, 07:03 PM
cgalpin's Avatar
cgalpin
Status: Offline
Charles Galpin
'94 D90 ST, '63 SeriesIIA
Site Team
 
Join Date: Jan 2004
Location: South Riding, VA
Posts: 11,625
Registry
Quote:
Originally Posted by rrc.swb View Post
I have a few new oil filters if you need them.
I got a whole bunch from the PO, thanks.

Quote:
Originally Posted by CDN90 View Post
Very Nice to hear she's running! I have been following the thread and now can say congratz! Enjoy.
Thanks.
Reply With Quote
Reply

Lower Navigation
Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions

Tags
start

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
HELP 94 d90 will not start ripp2002 Defender Technical Discussions 64 August 25th, 2005 08:43 AM
95 won't start, possible fuel priming issue? jcasteel Defender Technical Discussions 1 March 15th, 2005 09:45 AM
Rats! Now my D90 won't start. No power to fuel pump jcasteel Defender Technical Discussions 8 March 15th, 2005 09:42 AM
Non D90 Technical Question jump start polarity problem dnewman9 Defender Technical Discussions 4 September 6th, 2004 05:39 AM
Ignition Relocation = No Start...Help JRowe Defender Technical Discussions 5 March 8th, 2004 12:45 PM


All times are GMT -5. The time now is 04:38 AM.


Copyright