No sound from speakers - Defender Source
Defender Source  

Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions

Join the Defender Source Community Today

Thread Tools
Old August 6th, 2009, 02:53 PM
Status: Offline
John Bartlett
Join Date: May 2008
Location: Poulsbo,WA,USA
Posts: 2
Unhappy No sound from speakers

97 defender radio seems to be working but no sound comes out of noise makers (speakers). Has anyone had or knows what my problem could be???

Reply With Quote
Old August 6th, 2009, 11:41 PM
Stmpede's Avatar
Status: Offline
Andrew Najarian
'93 NAS D110 #43
Join Date: Mar 2007
Location: Jacksonville, FL
Posts: 2,460
Have you checked your fuses? There may be a second fuse for the amp. I am not sure if the '97 came with an amp, but my 110 did and that is the first thing I would check. When we pull the amp fuse for auto shows the radios still work as they should, but there is no sound.
"I have taken more good from alcohol than alcohol has taken from me." - Winston Churchill
Reply With Quote

Lower Navigation
Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Sound Dampening Material kellymoe Misc. Chit-Chat 1 March 13th, 2005 01:34 PM
Fuel Pump Sound ronward Defender Technical Discussions 4 January 10th, 2005 07:45 AM
Exact replacements for OEM speakers Kimos Defender Technical Discussions 6 December 21st, 2004 12:46 PM
Tapping sound from brakes? Cyborg Defender Technical Discussions 7 August 1st, 2004 07:57 PM
Power amp & 2 speakers 4 sale januconn92 For Sale - Parts 0 April 14th, 2004 01:55 PM

All times are GMT -5. The time now is 08:24 PM.