No Power! - Defender Source
Defender Source  

Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions


Reply
 
Thread Tools
  #1  
Old June 20th, 2005, 11:57 AM
vlcmstnscout
Status: Offline
Tony Brown
Member
 
Join Date: Jun 2005
Location: Monroe, Ct, USA
Posts: 1
Post No Power!

ive got a 94 and after sittin for a while it stopped getting fuel to the engine. i replaced the fuel pump but still nothing. it wont start, well with starting fluid itll start, but that sux, its getting no power at all please help badly!
Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old June 20th, 2005, 12:54 PM
Mike Hippert's Avatar
Mike Hippert
Status: Offline
D-90Slut/Stalker,SNLPres
94 D-90 Grinding Rover
Member
 
Join Date: Sep 2003
Location: Manchester NH USA
Posts: 4,789
Can you hear the fuel pump come on?
__________________
Don't forget to
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
first then ask questions later! The loose nut behind the wheel
Reply With Quote
  #3  
Old June 20th, 2005, 11:35 PM
Hans's Avatar
Hans
Status: Offline
Hans Haase
The D-90.com Lab Rat
Member
 
Join Date: Oct 2003
Location: Long Island, NY
Posts: 2,381
Just a random list of things to check.

Fuel Filter
Fuel Pump
Fuses
Relays
Pressure Regulator
wiring
Errr.... Got Gas?

-Hans
__________________
My oil line fix

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
My 100k stopped odometer fix

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Brace for impact, I'm in a "modifying mood". Massive thread count inbound.
Reply With Quote
Reply

Lower Navigation
Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
300 Tdi Egt Q?????? Buckon37s Defender Technical Discussions 37 July 11th, 2012 11:26 AM
Power Locks in a ST? mod4b Defender Technical Discussions 9 June 17th, 2005 02:32 PM
Loss of power Leadfoot Defender Technical Discussions 4 January 28th, 2005 03:36 PM
Power Windows (was: Leccy Windows!!!!!) P1CR Defender Technical Discussions 21 February 28th, 2004 01:14 PM


All times are GMT -5. The time now is 11:59 PM.


Copyright