NO Headlights - Fuses All Good/MOD pls Delete - Defender Source
Defender Source  

Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions


Reply
 
Thread Tools
  #1  
Old October 10th, 2009, 11:45 AM
BlackDog
Status: Offline
A. Fehd
95 90ST
Member
 
Join Date: Apr 2006
Location: Charlottesville, VA
Posts: 23
NO Headlights - Fuses All Good/MOD pls Delete

Plugged my trailer in last weekend (four prong) and went to haul away some brush, had the headlights on for 30 seconds when the dash went dim. Pulled the lights switch off and then back into "running lights". Running lights are working in first "light" stalk position, turn signals working fine.

When I throw switch for full headlight and running lights I get nothing. All fuses are fine as are the BIG ones in the engine bay against the firewall. Truck starts/runs, etc.

What am I missing? Light relay? Thanks ahead of time.

Follow-up Post:

Apologies here - broke sticky rule #1 and didnt search. MOD please delete. Same symptoms as others had, burned my small switch up apparently.

MOD please delete.
Reply With Quote
Sponsored Links
Advertisement
 
Reply

Lower Navigation
Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions

Tags
ht, lights, mod

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Low Beam Headlights Quit JimC Defender Technical Discussions 7 January 29th, 2006 07:54 PM
Headlights - switch problem? mgrgpg Defender Technical Discussions 3 December 14th, 2005 03:42 PM
Yaaaaaaaaaaaarg! Frigging headlights solihul Defender Technical Discussions 2 June 23rd, 2005 10:29 PM
Help - My 90's headlights don't work solihul Defender Technical Discussions 5 May 20th, 2005 01:27 AM
97 D-90 SW blowing fuel pump fuses intermittantly BarryO Defender Technical Discussions 9 July 20th, 2004 03:07 PM


All times are GMT -5. The time now is 10:12 AM.


Copyright