No electric? No power to ANYTHING please help - Defender Source
Defender Source  

Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions


Reply
 
Thread Tools
  #1  
Old April 19th, 2012, 08:31 PM
bar11's Avatar
bar11
Status: Offline
rob grentz
1994 defender 90
Member
 
Join Date: Mar 2011
Location: United States
Posts: 149
No electric? No power to ANYTHING please help

I have a NAS d90 and have had it on a battery tender for the winter and have started it occasionally but today when I went to drive it there was no power I mean no electrical power when I turn the key nothing the lights don't work or the flashers I mean it's like dead to the world?? Is there a main fuse to check? Any ideas or suggestions are welcome Thanks in advance Rob I accidentally also posted this in the series discussion "sorry"
Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old April 19th, 2012, 09:13 PM
Viton's Avatar
Viton
Status: Offline
Deaf Ember
Smart 4x4
Member
 
Join Date: Jan 2009
Location: La
Posts: 1,231
I'd 1st start with a volt meter and test the battery voltage.
Reply With Quote
  #3  
Old April 23rd, 2012, 01:42 PM
ajh
Status: Offline
Andrew J. Hutton
1993 Defender 110 200TDI
Member
 
Join Date: Oct 2007
Location: Ottawa, Ontario, Canada
Posts: 735
Most common is a ground problem. If it uses the same braided grounding strap found on the RRC/D1 it commonly rots right through.
__________________
--

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
- Parts & Accessories Imported Weekly

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
- Like us on Facebook for a discount on parts!

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
- Handmade Soap ideal for Mechanics!
Reply With Quote
Sponsored Links
Advertisement
 
  #4  
Old April 23rd, 2012, 07:58 PM
maleger
Status: Offline
Marc-Andre Leger
94D90 CDN#18 http://rover.leger.ca
Member
 
Join Date: May 2010
Location: Montreal, Quebec, Canada
Posts: 395
Registry
There are big fuses in the engine bay, near the driver's side bulkhead, But you really need to check the voltage at the battery and the grind mentioned above. Then look at the wiring diagram and measure power starting at the battery, at the starter, at the alternator, etc. But most likely is a dead battery...
Reply With Quote
  #5  
Old April 24th, 2012, 07:58 PM
bar11's Avatar
bar11
Status: Offline
rob grentz
1994 defender 90
Member
 
Join Date: Mar 2011
Location: United States
Posts: 149
Thanks for all the great advise but I'm a goof the battery was super dead i assumed that since it was on a trickle charge it would be fine not thinking the charger may have gone bad..... yeah I know what assume means thanks again ROB
Reply With Quote
Reply

Lower Navigation
Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
300 Tdi Egt Q?????? Buckon37s Defender Technical Discussions 37 July 11th, 2012 11:26 AM
Did 1995 SW D90s come with an electric fan? arbik Defender Technical Discussions 8 March 1st, 2005 01:27 AM
Loss of power Leadfoot Defender Technical Discussions 4 January 28th, 2005 03:36 PM
electric driven ps pump ??? artm Defender Technical Discussions 12 July 16th, 2004 09:30 PM
Power Windows (was: Leccy Windows!!!!!) P1CR Defender Technical Discussions 21 February 28th, 2004 01:14 PM


All times are GMT -5. The time now is 04:00 PM.


Copyright