New VDO Speedo is occasionally flickering - Defender Source
Defender Source  

Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions


Reply
 
Thread Tools
  #1  
Old April 28th, 2012, 05:21 PM
Manimal's Avatar
Manimal
Status: Offline
Carl Jonsson
1995 NAS D90 #219
Site Team
 
Join Date: Sep 2008
Location: Portland, OR
Posts: 3,236
New VDO Speedo is occasionally flickering

I noticed that my relatively new VDO speedo needle tends to flicker sometimes. Once in a while it'll jump to 0 then back to actual speed. I drove to work one day and noticed it bouncing around quote a bit but to only seems to happen on occasion. Is it a grounding issue or is it the sender... or the gauge itself?
Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old May 11th, 2012, 11:57 AM
Manimal's Avatar
Manimal
Status: Offline
Carl Jonsson
1995 NAS D90 #219
Site Team
 
Join Date: Sep 2008
Location: Portland, OR
Posts: 3,236
Now it's gone from flickering to completely dead. It lights up and shows milage but the needle doesn't move. Ive check connectors on the back of the gauge and I've checked that the transducer hasn't come out. What's the deal? Is the little metal peg inside the transducer not engaging? Has anyone else had this problem?
__________________
Land Rovers. A loosely associated collection of parts, generally traveling in the same direction.
Reply With Quote
  #3  
Old May 11th, 2012, 12:17 PM
Red90's Avatar
Red90
Status: Offline
John B.
1991 Defender 90, 200TDI
Site Team
 
Join Date: Sep 2003
Location: Calgary
Posts: 9,226
Registry
I would double check all connections... IME, this is normally the problem. The senders are very simple and hard to kill.
Reply With Quote
Sponsored Links
Advertisement
 
  #4  
Old May 11th, 2012, 01:13 PM
Manimal's Avatar
Manimal
Status: Offline
Carl Jonsson
1995 NAS D90 #219
Site Team
 
Join Date: Sep 2008
Location: Portland, OR
Posts: 3,236
...and now its working again. I double checked connections. Transducer was pretty snug already so i'm not sure what is up. Just wait and see if it does it again I guess.
__________________
Land Rovers. A loosely associated collection of parts, generally traveling in the same direction.
Reply With Quote
  #5  
Old May 11th, 2012, 01:25 PM
Red90's Avatar
Red90
Status: Offline
John B.
1991 Defender 90, 200TDI
Site Team
 
Join Date: Sep 2003
Location: Calgary
Posts: 9,226
Registry
The signal wires and connections need to be really good. Even a slightly bad connection plays havoc on the signal.
Reply With Quote
  #6  
Old May 11th, 2012, 05:56 PM
Manimal's Avatar
Manimal
Status: Offline
Carl Jonsson
1995 NAS D90 #219
Site Team
 
Join Date: Sep 2008
Location: Portland, OR
Posts: 3,236
I thought I did a fantastically thorough job of wiring it up. Heat-shrunk everything with Ancor products. Working for now.
__________________
Land Rovers. A loosely associated collection of parts, generally traveling in the same direction.
Reply With Quote
  #7  
Old May 11th, 2012, 06:19 PM
Red90's Avatar
Red90
Status: Offline
John B.
1991 Defender 90, 200TDI
Site Team
 
Join Date: Sep 2003
Location: Calgary
Posts: 9,226
Registry
How are you connected to the speedo. Do you have the VDO multi-pin connector or are you using individual spade connectors? Are they nice and tight? I had the same thing happen and it was a slightly loose spade at the speedo.
Reply With Quote
  #8  
Old May 11th, 2012, 07:01 PM
Manimal's Avatar
Manimal
Status: Offline
Carl Jonsson
1995 NAS D90 #219
Site Team
 
Join Date: Sep 2008
Location: Portland, OR
Posts: 3,236
Individual spade connectors. That could very well be it. They didn't appear loose but this morning I wiggled them as tight as I could and it's been good since.
__________________
Land Rovers. A loosely associated collection of parts, generally traveling in the same direction.
Reply With Quote
Reply

Lower Navigation
Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions

Tags
speedo

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
VDO SPeedo roverboy Defender Technical Discussions 69 March 1st, 2015 10:35 AM
VDO Speedo help timtimtj Defender Technical Discussions 6 October 24th, 2010 10:16 PM
?????? jimmy salmon Defender Technical Discussions 8 October 13th, 2005 11:54 AM
VDO speedo for sale vlocci For Sale - Parts 3 May 2nd, 2004 12:38 PM
VDO speedo for sale vlocci For Sale - Parts 2 January 9th, 2004 11:32 AM


All times are GMT -5. The time now is 04:42 AM.


Copyright