Need more help on electrical issue - Defender Source
Defender Source  

Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions


Reply
 
Thread Tools
  #1  
Old September 25th, 2013, 08:46 PM
akrockhound's Avatar
akrockhound
Status: Offline
Jack
1988 RHD 110
Member
 
Join Date: Dec 2012
Location: Alaska, Washington
Posts: 106
Registry
Exclamation Need more help on electrical issue

1988 110 RHD V-8

One day my right side low beam stopped working. shortly thereafter my left side high beam quit. So I have left side low beam and right side high beam.

Logical answer was switch - changed it and turn signal switch for new Lucas. Problem persists. DipDim was already unplugged and remains unplugged.

Fuses are all good.

What the hell else can I check?
Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old September 25th, 2013, 09:09 PM
Mybluett's Avatar
Mybluett
Status: Offline
Defenders Northwest
110SW
D-90 Source Vendor
 
Join Date: Dec 2011
Location: Gig Harbor, WA
Posts: 2,007
Registry
Quote:
Originally Posted by akrockhound View Post
1988 110 RHD V-8

One day my right side low beam stopped working. shortly thereafter my left side high beam quit. So I have left side low beam and right side high beam.

Logical answer was switch - changed it and turn signal switch for new Lucas. Problem persists. DipDim was already unplugged and remains unplugged.

Fuses are all good.

What the hell else can I check?
bulbs are good if you swap sides?
Reply With Quote
  #3  
Old September 25th, 2013, 09:21 PM
Overlander's Avatar
Overlander
Status: Offline
mark kellgren
in between D's in an 04 D2
Member
 
Join Date: Mar 2006
Location: Charlotte, NC
Posts: 6,531
Registry
Circuit on a D is very simple. Each light (2x hi, 2xlow) have a circuit that goes from switch, through it's own fuse and straight to light connection. If you are sure the fuse is good, then it sounds like it's at the bulb. To confirm, pull your bulbs out, and use a circuit tester to each lead. each bulb has 3 connections. Hi+, Low+ and ground. if you get 12v on all four positive, it's the bulb or the ground.
__________________
Mark Kellgren
KM4BOR

ISIL and al qaeda can go F*ck themselves...
Reply With Quote
Sponsored Links
Advertisement
 
  #4  
Old September 25th, 2013, 10:07 PM
Uncle Douglas's Avatar
Uncle Douglas
Status: Offline
Doug Crowther
A defender in every driveway-motto
D-90 Source Vendor
 
Join Date: Dec 2007
Location: Gods Country- Central Virginia
Posts: 11,833
Registry
Like Brian I'd assume the bulbs. Sealed beams usually fail withing a week of one another when replaced as pairs. That said glass fuses don't have to be blown to stop working.
__________________
Good judgement comes from experience,experience comes from bad judgement.

Dividing Creek Imports
Worldwide Vehicle Shipment and Importation Service
Restoration & Modification work


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

410.693.1391


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Reply With Quote
  #5  
Old September 25th, 2013, 10:17 PM
akrockhound's Avatar
akrockhound
Status: Offline
Jack
1988 RHD 110
Member
 
Join Date: Dec 2012
Location: Alaska, Washington
Posts: 106
Registry
thanks

I will report back when I have some joy
Reply With Quote
  #6  
Old September 25th, 2013, 11:29 PM
Mybluett's Avatar
Mybluett
Status: Offline
Defenders Northwest
110SW
D-90 Source Vendor
 
Join Date: Dec 2011
Location: Gig Harbor, WA
Posts: 2,007
Registry
Quote:
Originally Posted by akrockhound View Post
I will report back when I have some joy
If not fixed soon I will be in Anchorage for a few days in Oct and can come up your way to lend a hand.
Reply With Quote
  #7  
Old September 25th, 2013, 11:48 PM
akrockhound's Avatar
akrockhound
Status: Offline
Jack
1988 RHD 110
Member
 
Join Date: Dec 2012
Location: Alaska, Washington
Posts: 106
Registry
In Fairbanks

If you are serious and Fairbanks is on your trip route - call me and come by for a look at my project. I am barely started - this light issue cropped up unexpectedly and what I hate about it is it prevents me from driving the thing in between working on it. 907-590-9332
Reply With Quote
  #8  
Old September 28th, 2013, 08:20 PM
akrockhound's Avatar
akrockhound
Status: Offline
Jack
1988 RHD 110
Member
 
Join Date: Dec 2012
Location: Alaska, Washington
Posts: 106
Registry
All's well that ends well - I wish I could boast about my electrical prowess and tell you I confidently trouble shot this to conclusion. BUT instead I replaced the switches and all the fuses and cleaned the oxidation out of the fuse block seats and everything works fine now.

Frankly I am not sure it wasn't some oxidation on the fuse socket seats the whole time!

I wasted some time putting in one fuse at a time and testing high beam/low beam/running lights etc. It looked like I still had issues until all circuit breakers were in. Then everything worked fine.

Thanks for your help on this. I am really just getting started on a couple years of off/on rolling restoration work on this 1988 110 and I really like it compared to my old Series III.
Reply With Quote
  #9  
Old October 12th, 2013, 01:21 PM
Mybluett's Avatar
Mybluett
Status: Offline
Defenders Northwest
110SW
D-90 Source Vendor
 
Join Date: Dec 2011
Location: Gig Harbor, WA
Posts: 2,007
Registry
Quote:
Originally Posted by akrockhound View Post
If you are serious and Fairbanks is on your trip route - call me and come by for a look at my project. I am barely started - this light issue cropped up unexpectedly and what I hate about it is it prevents me from driving the thing in between working on it. 907-590-9332
I'll be in Fairbanks on the 17th if you want to meet up for a bit.

Brian@defendersnw.com
__________________
Defender Parts, Service, Restoration, and Training

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Reply With Quote
Reply

Lower Navigation
Go Back   Defender Source > Defender & Series Technical Discussions > Defender Technical Discussions

Tags
electrical

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Electrical issue? Turn Signal / Brake pedal Flagg Defender Technical Discussions 5 November 9th, 2012 02:08 PM
NAS D110 Electrical Issue 61rover Defender Technical Discussions 9 April 18th, 2012 10:31 PM
Electrical Issue lordhelemt Defender Technical Discussions 1 June 26th, 2011 09:15 PM
HELP!! Weird electrical issue phoenix37 Defender Technical Discussions 18 March 20th, 2010 02:36 PM
Need help diagnosing electrical issue cgalpin Defender Technical Discussions 22 January 25th, 2007 08:53 PM


All times are GMT -5. The time now is 01:34 PM.


Copyright